Willkommen im kivitendo Forum! Hier erweitern und teilen AnwenderInnen und EntwicklerInnen ihr Wissen.

Teste kivitendo!

kivitendo Demo

kivitendo Demo mit Schweizer Kontenplan

Geld allein macht nicht glücklich - benutzt kivitendo!

0 Punkte

Hallo kivitendo User,

Ich habe eine frische Installation auf einem Debian 7 Server vorgenommen. Bis jetzt hat alles geklappt, dank der guten Anleitungen im Netz.

Ich habe einen neuen Benutzer, Mandanten und ein Gruppe erstellt, diese Daten bzw. die Datenbank konnte durch den Test-Button geprüft werden. Datenbank ist ok.

Wenn ich nun nach der Speicherung auf den Benutzer-Login wechsele, meine vorher gesetzten Benutzerdaten und das Passwort eingebe, erscheint eine Fehlermeldung: Falsches Passwort, Benutzer oder Mandant.

Anmerkung: Der Server ist noch nicht vollständig konfiguriert, dass heißt, ich habe noch kein Frontend installiert. Damit meine ich bei direkter Eingabe der Url des Webservers, kommt nur die Meldung: "It works"

Ich melde mich also so über das System an: IP/kivitendo/controller.pl?

Meiner Meinung nach ist dies aber nicht der Grund des fehlerhaften Logins im Benutzeranmeldungsmenü.

Muss ich noch von Hand in den config Dateien, die neuen Nutzer nachtragen?

MFG

Chrufru

P.S. Ist es eigentlich möglich das Modul (Wo ist Bob) Projektmanagement zu installieren? Früher gab es das mal… finde keine Infos darüber….

Gefragt von (20 Punkte)

2 Antworten

0 Punkte

Ich habe einen neuen Benutzer, Mandanten und ein Gruppe erstellt,
diese Daten bzw. die Datenbank konnte durch den Test-Button geprüft
werden. Datenbank ist ok.

Anmerkung: Der Server ist noch nicht vollständig konfiguriert, dass
heißt, ich habe noch kein Frontend installiert.

Diese beiden Aussagen passen nicht zusammen, wenn man kein Frontend hat kann man auch im Adminbereich keine Mandanten konfigurieren.

Benutzeranmeldung ist unter:
controller.pl?action=LoginScreen/user_login
Oder komplett weglassen, dann sollte es automatisch einen Redirect geben.

Aus dem Adminbereich heraus gibt es auch noch einen Link zum Benutzerlogin in einem der Menüs.

Beantwortet von (16.3k Punkte)

OK, dann ist das Frontend installiert. Ich habe in einem anderen Thread gelesen dass, es an der Erstanmeldung der Datenbank liegen könnte. Ich habe mehrere Benutzer unter potgres angelegt weil, ich Schwierigkeiten mit dem Admin login hatte… Nun weiß ich nicht mehr welchen ich bei der Erstanmeldung der Datenbank genutzt habe, kann ich das irgendwo einsehen?

Gibt es einen Befehl wo alle postgres Nutzer die ich angelegt habe in der Konsole abzufragen sind?

Benutzeranmeldung ist erreichbar unter: X.X.X.X/kivitendo/controller.pl?action=LoginScreen/user_login

Sorry für die Bezeichnung Frontend. Habe da was verwechselt.

Unter Mandanten bearbeiten habe ich folgendes eingegeben:
Datenbankname: postgres
Datenbankhost und -port: localhost
Datebankbenutzer und -passwort:lxoffice

Wie schon oben erwähnt, funktioniert Datenverbindung testen, trotzdem kein Login möglich….

Nachtrag: Da der Server keine grafische Oberfläche besitzt (Browser), frage ich mich gerade warum es überhaupt möglich ist mich als Admin von Aussen (Internet) auf den Server einzuloggen obwohl ich in den Konfig's nur den localhost konfiguriert habe. Ich bin ein Anfänger was Serversaministration betrifft. Denke aber das dies eigentlich nicht sein dürfte….

Mfg

Chrufru

>> Nachtrag: Da der Server keine grafische Oberfläche besitzt (Browser), frage ich mich gerade warum es überhaupt möglich ist mich als Admin von Aussen (Internet) auf den Server einzuloggen obwohl ich in den Konfig's nur den localhost konfiguriert habe. Ich bin ein Anfänger was Serversaministration betrifft. Denke aber das dies eigentlich nicht sein dürfte….

Gibt es dafür eine Erklärung? Sollte meiner Meinung nach mit einer Standart Installation über Git nicht möglich sein...

Du bist mit git im entwicklerzweit von kivitendo. Du musst einen Branch erstellen der sich an einem tag orientiert (normalerweise die aktuelle stable) Lass von allem anderen die Finger, das kann ungluecklich machen.

Zurueck auf Stable kannst Du jetzt nicht, aber geh auf die aktuelle Beta und nach relaese auf die neue Stable

0 Punkte

Ich habe einen neuen Benutzer, Mandanten und ein Gruppe erstellt, diese Daten bzw. die Datenbank konnte durch den Test-Button geprüft werden. Datenbank ist ok.

Wenn ich nun nach der Speicherung auf den Benutzer-Login wechsele, meine vorher gesetzten Benutzerdaten und das Passwort eingebe, erscheint eine Fehlermeldung: Falsches Passwort, Benutzer oder Mandant.

Du hast die beta installiert? Du hast den Benutzer der Gruppe zugefuegt? Du hast den Benutzer dem Mandanten zugeordnet? Du hast beim Login sowhol den Benutzer wie auch den Mandanten ausgewaehlt?

Anmerkung: Der Server ist noch nicht vollständig konfiguriert, dass heißt, ich habe noch kein Frontend installiert. Damit meine ich bei direkter Eingabe der Url des Webservers, kommt nur die Meldung: "It works"

Klingt alles ein bisschen danach, dass Du mal eine grossen Kuchen backen und einen befreundeten Admin zu Dir einladen solltest. "it Works" bringt Deine Apache Installation mit, das hat nix mit kivitendo zu tun.
Wenn Du Dich an die Doku gehalten hast, ist kivitendo unter SERVER/kivitendo/ erreichbar. Alse ist SERVER/ nicht Teil von Kivitendo.

Ich melde mich also so über das System an: IP/kivitendo/controller.pl?

eigentlich nein, da bringt das Programm Dich dann zwar hin, aber Du meldest Dich unter

Benutzeroberflaeche: SERVER/kivitendo/
Administration: SERVER/kivitendo/admin.pl

Meiner Meinung nach ist dies aber nicht der Grund des fehlerhaften Logins im Benutzeranmeldungsmenü.

richtig, siehe meine Fragen oben.

Muss ich noch von Hand in den config Dateien, die neuen Nutzer nachtragen?

nein.

P.S. Ist es eigentlich möglich das Modul (Wo ist Bob) Projektmanagement zu installieren? Früher gab es das mal… finde keine Infos darüber….

soweit ich weiss ist das Projekt eingestellt

Beantwortet von (17.9k Punkte)

Hallo Wulf,

trotzdem hilfreich.

Du hast die beta installiert? Du hast den Benutzer der Gruppe zugefuegt? Du hast den Benutzer dem Mandanten zugeordnet? Du hast beim Login sowhol den Benutzer wie auch den Mandanten ausgewählt?

1.) Wo sehe ich das? Weder im /var/www/kivitendo-erp-3.0.0/ ,noch auf dem Adminpanel sehe ich was von Beta.
2.) Ich denke schon. Werde es nochmals überprüfen
3.) Ja habe ich. Zumindest denke ich das- Bitte genauer Erklären.
4.) Definitiv beide ausgewählt. Mit dem neu erstellten Passwort, mit dem man auch die DB testen kann.

Klingt alles ein bisschen danach, dass Du mal eine grossen Kuchen backen und einen befreundeten Admin zu Dir einladen solltest. "it Works" bringt Deine Apache Installation mit, das hat nix mit kivitendo zu tun.
Wenn Du Dich an die Doku gehalten hast, ist kivitendo unter SERVER/kivitendo/ erreichbar. Alse ist SERVER/ nicht Teil von Kivitendo.

Mir war klar das kivitendo nur ein Teil des Servers ist. Ich war und bin mir eben unsicher dass, ich den Localhost von einem anderer Rechner aus übergehen konnte.

Dabei fehlen mir natürlich ein paar Grundlagen, es ging auch eher um eine Präsentation eines Systems. Ein Testbetrieb.

Es war geplant den Kuchen von einem gelernten Systemadmin betreuen zu lassen. Ich wollte aber zeigen wie das System aussieht. Insbesondere interessierte mich das Projektmanagement Modul Bob, welches wie du sagtest, eingestampft zu sein scheint. Ich hatte mir vor 2 Jahren das Projektmanagement angeschaut, es gefiel mir. Darum habe ich durch lesen dieser Seiten:

Bob zieht um
und dieser:
kivitendo lernt Projektmanagement
mich entschlossen es in meiner Freizeit zu versuchen, dieses System zu installieren um es Präsentieren zu können. Das ich gewisse Sicherheitsaspekte nicht zu beurteilen mag, ist möglich.

Da es das Gesetz "Unwissenheit schützt vor Strafe nicht" Gesetz gibt. Sollte ich dabei natürlich vorsichtig sein, einen Server mit IP im Internets zu haben. Ich ging davon aus dass, es möglich ist auch ohne große Vorkenntnisse, durch Lesen und durch die Fragen&Antworten-Methode zum gewünschten Ziel zu kommen ohne große Risiken einzugehen.

Wenn es aber zu umfangreich ist, so ein System auch im Testbetrieb sicher zu halten, werde ich lieber die Finger davon lassen.

Achso, Anmerkung ich bin diese Anleitung durchgegangen:
Installation_Debian wobei ich auf Git über diese Seite:kivitendo git gelangt bin.

1.) Wo sehe ich das? Weder im /var/www/kivitendo-erp-3.0.0/ ,noch auf dem Adminpanel sehe ich was von Beta.

git log

eine Installation aus dem git ist das praktischste und stressfreiste was man machen kann, ohne git-Kentnisse wuerde ich davon aber dringend Abstand nehmen.

Ich war und bin mir eben unsicher dass, ich den Localhost von einem anderer Rechner aus übergehen konnte.

Die Frage ist mir vollkommen unklar. localhost ist der dns-name fuer den Rechner auf dem man sich befindet.
Wenn man einen Dienst auf einem anderen Rechners erreichen will muss man natuerlich die IP-Adresse oder den dns-Namen des entsprechenden Rechners verwenden.

Ähnliche Fragen

0 Punkte
1 Antwort
0 Punkte
5 Antworten
0 Punkte
1 Antwort
...