Willkommen im kivitendo Forum! Hier erweitern und teilen AnwenderInnen und EntwicklerInnen ihr Wissen.

Teste kivitendo!

kivitendo Demo

kivitendo Demo mit Schweizer Kontenplan

Geld allein macht nicht glücklich - benutzt kivitendo!

0 Punkte

Hallo,
hier ein paar kurze Infos: ich betreibe Kivitendo auf Ubuntu 12.04 lts und benutze eine alte Datenbank die ich nun bis auf 3.0.0 gebracht habe jetzt komme ich nicht weiter ich habe 3.1.0 normal installierte und ./script/installationscheck -ro gemacht alles aktuell
so nun zu Fehlermeldung ich habe mich im Administrationsmenü angemeldet worauf ich Mandanten anlegen soll dies habe ich für 2 Datenbanken gemacht und habe auf weiter gedrückt anschließen kam folgende Fehlermeldung:

**

Datenbankaktualisierung (lxerp_auth)
Führe foreign_key_constraints_on_delete.pl aus: Ändert "FOREIGN KEY"
constraints auf "ON DELETE CASCADE" Die
Datenbankaktualisierung/erstellung schlug fehl. Die Datei
sql/Pg-upgrade2-auth/foreign_key_constraints_on_delete.pl enthielt den
folgenden Fehler: Fehler beim Datenbankupgrade: ALTER TABLE
auth.clients_groups ADD FOREIGN KEY (client_id) REFERENCES
auth.clients (id) ON DELETE CASCADE ERROR: relation
"auth.clients_groups" does not exist at
/var/www/lx-erp5/SL/DBUpgrade2/Base.pm line 41. Alle Änderungen in
dieser Datei wurden rückgängig gemacht.

**
So nun hab ich keine Ahnung was er genau von mir will bzw. wo der Fehler liegt.
wenn jemand ne Idee hat was ich machen könnte damit es funktioniert

PS: ich hatte es schon mal auf 3.1.0 auf einem anderen Rechner geupdate und da lief es ohne Probleme hat sich nix geändert alles gleich nur ein aktuellerer Datensatz

Danke im voraus

geschlossen mit Kommentar: Gelöst
Gefragt von (350 Punkte)
geschlossen von

1 Antwort

0 Punkte

Du hast wahrscheinlich eine Verfummelte Datenbank, denn hier hattest Du ja auch schon mal ein Konsistenz Problem

https://forum.kivitendo.de/2525/fehler-beim-update-von-2-6-3-auf-2-7-0

Ich gehe davon aus, das das sich nicht mal eben mit ein paar community Hinweisen loesen laesst und wuerde Dir raten einen Techniker mit in's boot zu nehmen.

Gerne haette ich Unrecht

Beantwortet von (17.9k Punkte)

oh Problem schon gelöst vergessen es auch so zu markieren Problem war das ich vergessen habe mich zuerst als admin anzumelden bevor ich die Nutzeranmeldung mache und das hat meine Datenbank ruiniert

Ähnliche Fragen

0 Punkte
1 Antwort
0 Punkte
1 Antwort
Gefragt 1, Sep 2014 von manufly (40 Punkte)
0 Punkte
2 Antworten
Gefragt 10, Apr 2014 von holgi (6.7k Punkte)
+1 Punkt
1 Antwort
...