Willkommen im kivitendo Forum! Hier erweitern und teilen AnwenderInnen und EntwicklerInnen ihr Wissen.

Teste kivitendo!

kivitendo Demo

kivitendo Demo mit Schweizer Kontenplan

Geld allein macht nicht glücklich - benutzt kivitendo!

0 Punkte

Hallo.

Sytem alt : Ubuntu 10.04 LTS
Writer : Openoffice
Kivitendo : 3.0

System neu : Ubuntu 14.04 LTS
Writer : Libreoffice
Kivitendo : 3.1

Habe meinen Server erneutert und im gleichen Atemzug bin ich auf Kivi3.1 umgestiegen.
Im Ubuntu 10.04 gab es in den Paketquellen noch Openoffice. Jetzt in Ubuntu 14.04 gibt es dies nicht mehr.
Ich habe statt dessen Libreoffice installiert. Laut eines Forumeintags hier, mußte nur der Pfad zum Writer angepasst werden (bei mir /usr/bin/lowriter).

Leider kommt beim erzeugen der PDF(Opendocument OASIS) ein Fehler.
(Rot hinterlegtes Feld mit Buchstabensalat)
Vor der Systemumstellung hat alles wunderbar funktioniert. Ich vermute das es mit dem Libreoffice Writer zusammen hängt. Bin mir da aber nicht sicher.
Ist ein solches Verhalten bekannt?

Gruß Maik

Gefragt von (310 Punkte)

2 Antworten

0 Punkte

Eventuell mal versuchen OO zu installieren.
Anleitung gibt es hier. Vielleicht klappt es ja.

Du könntest evtl. die Fehlermeldung auch mal hier posten.

Beantwortet von (710 Punkte)

Hallo Soeldner,

sorry für die späte Antwort, habe durch Emailwechsel keine Benachrichtigung mehr erhalten.

Habe mittlerweile Libreoffice probier und bin auch nach deiner Anleitung vorgegangen und habe OO4 installiert. Leider bei allen Versionen die gleiche Fehlermeldung (kivitendi-print|und dann Datenmüll|).

Jedesmal wenn ich ein OO Dokument in ein PDF konvertieren möchte schmeißt mir Apache fcgi einen stderr in der error.log

Bin gerade noch in einem Lehrgang. Füge nachher den Apache Log an.

Vielen Dank.
Mfg Maik

So hier nun der Log-Eintrag :

     [Wed Feb 11 23:05:56.448610 2015] [mpm_prefork:notice] [pid 2475] AH00163: 
   Apache/2.4.7 (Ubuntu) mod_fcgid/2.3.9 PHP/5.5.9-1ubuntu4.5 configured -- resuming normal operations

    [Wed Feb 11 23:05:56.448786 2015] [core:notice] [pid 2475] AH00094: Command line: '/usr/sbin/apache2'

    [Wed Feb 11 23:06:08.847482 2015] [fcgid:warn] [pid 2479] [client 192.168.123.101:52348] 
    mod_fcgid: stderr: Error: action= nicht definiert! 
    xauth:  file /tmp/.Xauthority-2488-1423692377-6526868 does not exist
    Initializing built-in extension Generic Event Extension
    Initializing built-in extension SHAPE
    Initializing built-in extension MIT-SHM
    Initializing built-in extension XInputExtension
    Initializing built-in extension XTEST
    Initializing built-in extension BIG-REQUESTS
    Initializing built-in extension SYNC
    Initializing built-in extension XKEYBOARD
    Initializing built-in extension XC-MISC
    Initializing built-in extension SECURITY
    Initializing built-in extension XINERAMA
    Initializing built-in extension XFIXES
    Initializing built-in extension RENDER
    Initializing built-in extension RANDR
    Initializing built-in extension COMPOSITE
    Initializing built-in extension DAMAGE
    Initializing built-in extension MIT-SCREEN-SAVER
    Initializing built-in extension DOUBLE-BUFFER
    Initializing built-in extension RECORD
    Initializing built-in extension DPMS
    Initializing built-in extension Present
    Initializing built-in extension DRI3
    Initializing built-in extension X-Resource
    Initializing built-in extension XVideo
    Initializing built-in extension XVideo-MotionCompensation
    Initializing built-in extension SELinux
    Initializing built-in extension GLX
    [Wed Feb 11 23:06:22.070718 2015] [fcgid:warn] [pid 2480] [client 192.168.123.101:52349] 
    mod_fcgid: stderr: Error: kivitendo-print5UZGyA : , 
    referer: http://192.168.123.120/kivitendo/oe.pl?action=edit&type=purchase_order&
    vc=vendor&id=6374callback=oe.pl%3faction%3dorders%26l_transdate%3dY%26l_reqdate%3dY%26
    l_ordnumber%3dY%26l_name%3dY%26l_amount%3dY%26l_employee%3dY%26l_delivered
   %3dY%26open%3d1%26delivered%3d1%26notdelivered%3d1%26type
   %3dpurchase_order%26vc%3dvendor%26sort%3dtransdate

Ich habe keine Erfahrung mit den openoffice Vorlagen, aber von der Fehlermeldung her würde ich tippen, daß versucht wird open/libreoffice im Grafikmodus zu starten, statt im Hintergrund.

0 Punkte

Hallo.

Hat noch jemand eine Idee woran das liegen könnte?

Gruß Maik

Beantwortet von (310 Punkte)

Ähnliche Fragen

0 Punkte
1 Antwort
0 Punkte
0 Antworten
0 Punkte
1 Antwort
Gefragt 6, Jul 2015 von Marek (350 Punkte)
...