Willkommen im kivitendo Forum! Hier erweitern und teilen AnwenderInnen und EntwicklerInnen ihr Wissen.

Teste kivitendo!

kivitendo Demo

kivitendo Demo mit Schweizer Kontenplan

Geld allein macht nicht glücklich - benutzt kivitendo!

0 Punkte

Hallo,

bei mir wird nach upgrade von 3.4.0 auf 3.5.3 folgender Fehler bei der Datenbankaktualisierung angezeigt:

Exception! The database update/creation did not succeed. The file sql/Pg-upgrade2/trigram_extension.sql containing the following query failed:
CREATE EXTENSION IF NOT EXISTS pg_trgm
The error message was: ERROR: syntax error at or near "PARALLEL"
All changes in that file have been reverted.

thrown at file /var/www/kivitendo-erp/SL/Form.pm, line 314 in Form::dberror, pid=15039
reached via file /var/www/kivitendo-erp/SL/DBUpgrade2.pm, line 197 in SL::DBUpgrade2::process_query
reached via file /var/www/kivitendo-erp/SL/DBUpgrade2.pm, line 299 in SL::DBUpgrade2::process_file
reached via file /var/www/kivitendo-erp/SL/User.pm, line 522 in User::dbupdate2
reached via file /var/www/kivitendo-erp/SL/User.pm, line 214 in User::login
reached via file /var/www/kivitendo-erp/SL/Controller/LoginScreen.pm, line 66

  in SL::Controller::LoginScreen::action_login

reached via file /var/www/kivitendo-erp/SL/Controller/Base.pm, line 264 in SL::Controller::Base::_run_action
reached via file /var/www/kivitendo-erp/SL/Dispatcher.pm, line 224 in SL::Dispatcher::_run_controller
reached via file /var/www/kivitendo-erp/SL/Dispatcher.pm, line 314 in SL::Dispatcher::handle_request
reached via file /var/www/kivitendo-erp/SL/Dispatcher.pm, line 232 in SL::Dispatcher::handle_all_requests
reached via file /var/www/kivitendo-erp/dispatcher.fpl, line 21 in

Kann mir jemand helfen, wo das Problem ist? Komme hier leider nicht weiter.

Danke Karsten

Gefragt von (200 Punkte)

1 Antwort

0 Punkte

Hallo Karsten,
konntest Du das Problem lösen? Ansonsten denke ich liegt es daran, dass Postgres nicht richtig konfiguriert ist. Seit Version 3.5.1 braucht es eine Erweiterung und einen Postgres Superuser.
siehe changelog

Upgrade auf v3.5.1
* Zwingende Postgres Erweiterung pg_trgm(Trigram)

und Dokumentation
https://www.kivitendo.de/kivi/doc/html/ch02s05.html#Erweiterung-für-trigram

Gutes Gelingen
Werner Hahn
Kivitendodienstleister

Beantwortet von (5.4k Punkte)

Inzwischen läuft mein System wieder. Habe die ganzen Prozeduren durchgeführt, wie in der Installationsdoku beschrieben. Danach ging immer noch nix. Hab dann die kompletten Datenbanken gesichert und wiederhergestellt. Auf einmal ging alles wieder. Bis auf die Eingabemasken in der Browseroberfläche. Aber durch ein löschen des Browsercache hab ich dieses Problem auch gelöst.

Leider muss ich mal feststellen, daß ich bisher bei jedem upgrade Probleme hatte. Da ich die software als Selbständiger Einzelunternehmer nutze ist das immer sehr ärgerlich, da ich dann immer ca. 20 Srunden damit beschäftigt bin, das ganze wieder zum laufen zu bringen. Bin halt kein admin, der täglich irgendwelche configs an Linux-Systemen macht.

Gruß
Karsten

Hi Karsten,
falls immer solche Probleme beim Upgraden passieren, kurz zwei Hinweise dazu:

i)
Ein offiizieller Dienstleister sollte nur ca 10% deiner veranschlagten Zeit für ein Upgrade benötigen. Ggf. die Upgrades outsourcen, um dann mehr Zeit für das Kerngeschäft zu haben
ii)
Niemals oder seltener Upgraden
iii)
Ein guter kivi-Berater kombiniert die Anforderungen aus I) + ii), zum höchsten Wohle des Kunden.

Gruß

Ähnliche Fragen

0 Punkte
0 Antworten
Gefragt 7, Jan 2016 von kbroszat (200 Punkte)
0 Punkte
1 Antwort
Gefragt 11, Jan 2016 von kbroszat (200 Punkte)
0 Punkte
0 Antworten
0 Punkte
1 Antwort
Gefragt 11, Sep 2018 von AEITB (420 Punkte)
0 Punkte
0 Antworten
Gefragt 29, Dez 2017 von quercus (20 Punkte)
...