Willkommen im kivitendo Forum! Hier erweitern und teilen AnwenderInnen und EntwicklerInnen ihr Wissen.

Teste kivitendo!

kivitendo Demo

kivitendo Demo mit Schweizer Kontenplan

Geld allein macht nicht glücklich - benutzt kivitendo!

0 Punkte

Hallo, guten Tag!
Ich habe die 3.5.4 installiert, auf postgres ein Passwort gesetzt, dann mit pgsql -f die Daten aus einer 3.4.1 Installation eingespielt (mit pg_dumpall erstellt).

Es läuft der apache2, postgres 10 und perl 5.10 (openSuse 15.1)

Das Programm startet mit der Anmeldemaske. Nach dem Einloggen als Admin läuft das Upgradescript ohne Fehlermeldung. Es scheint aber die Zuordnung von Benutzer, Gruppe und Rechte verloren gegangen zu sein. Die Datenbanken sind da, aber ein keinerlei Auswahl ist möglich. Es kann auch kein neuer Benutzer angelegt werden.

Als Benutzer kann ich mich anmelden, auch da läuft das Upgradescript fehlerfrei durch. Ich habe aber kein Menu.

Wo kann ich bei der Fehlersuche ansetzen?

Vielen Dank für eure Mühe.

Fritz
Ps: Es ist nichts Dringendes, nur Interesse. Ich habe eine lauffähige Installation auf openSuse 15.1 mit der3.4.1 und cherry-picking

Gefragt von (940 Punkte)

2 Antworten

+1 Punkt

Hi,
ich würde mal schauen ob die beiden DBs vollständig da sind und die Zugriffsrechte des DB-Nutzers stimmen.
Geraten:
Auf dem alten System war wahrscheinlich noch ein andere DB-Nutzer eingetragen ODER die Auth-DB ist nur teilweise vorhanden.

Beantwortet von (7.6k Punkte)

Moin,
vielen Dank für Deine Antwort!

Die DB-Benutzer stimmen überein. Ich verwende die gleichen config Einträge.
Welche beiden DBs meinst Du? Die kivitendo_auth ist vorhanden. Ich kann sie auch mit webmin oder pgadmin einsehen. Alle Tabellen sind vorhanden und die eingetragenen Werte stimmen überein (bis auf OIDs und die Felder, die durch die updatescripts erzeugt wurden).
Die DB-Rechte habe ich (um alle Zugriffe zu ermöglichen) auf postgres:postgres und 700 für data und 777 für alle Unterverzeichnsse gesetzt. Es ändert sich aber auch nichts, wenn ich die Rechte so wie bei der Erstinstallation belasse.

Ich stehe wirklich vor einem Rätsel!
Grüße zum Wochenende
Fritz
Ups, ich habe im obiger Frage die Perlversion falsch angegeben. es ist natürlich 5.26!

0 Punkte

Versuche doch mal die DB mit

su postgres -c "pg_dump -o -O DB-Name > name.sql" 

zu sichern und mit

su postgres -c "dropdb db_name && createdb db_name && psql db_name < name.sql"

auf der neuen Maschine anzulegen
Vorher noch PostgreSQL neu starten.

Das PostgreSQL-Passwd änderst du in der Konsole mit

psql template1
alter role postgres with password 'kivitendopasswd';
/q

Sollte es dann immer noch nicht funktionieren so poste doch mal die Error.log deines Webservers.
tail -f /var/log/apache2/error.log (bei den debinoiden Systemen)

Viele Grüße

Ronny

Beantwortet von (8.4k Punkte)

Hallo,

vielen Dank für Deine Antwort.
Ich werde Deine Vorschläge ausprobieren und dann berichten. Wird aber etwas dauern.
Kannst Du mir bitte noch sagen, welche DB? Es sind ja mehrere, oder jede einzeln sichern und zurücksichern?

Dann habe ich noch eine Verständnisfrage. In der Anleitung wird erstmals verlangt, für den user postgres ein pw einzurichten. Wozu ist das erforderlich? Zumindest bei meiner Opensuse Installation kann der user postgres eh nur von root aufgerufen werden, ob mit oder ohne pw.

Dankeschön

Fritz

Es sind zwei Datenbanken.
kivitendo_auth (für die Benutzerdaten)
deinefirna (für die Daten deiner Firma, Rechnungen, ect

Für die Datenbank "kivitendo_auth" steht das Passwd in less /var/www/kivitendo-erp/config/kivitendo.conf

Wenn du unter admin.pl eine Datenbank anlegst so musst du Benutzername und Passwd eingeben.

Dort sollte als Benutzer "postgres" und bei Passwort "denPasswd" eingetragen werden.

Viele Grüße aus Zürich..

Ronny

Ähnliche Fragen

0 Punkte
1 Antwort
Gefragt 28, Jan 2014 von Fritz Pörschke (940 Punkte)
0 Punkte
2 Antworten
Gefragt 31, Mär 2018 von silencer2010 (850 Punkte)
0 Punkte
1 Antwort
Gefragt 4, Nov 2017 von christian.decker (30 Punkte)
0 Punkte
0 Antworten
...