Willkommen im kivitendo Forum! Hier erweitern und teilen AnwenderInnen und EntwicklerInnen ihr Wissen.

Teste kivitendo!

kivitendo Demo

kivitendo Demo mit Schweizer Kontenplan

Geld allein macht nicht glücklich - benutzt kivitendo!

0 Punkte

Hallo,

nachdem ich auf noch Ubuntu 14.04 eine neues Kivitendo aufgesetzt habe, bin ich bis zum Einloggen in den Administrationsbereich gekommen. Die Datenbank zur Benutzerauthentifizierung habe ich angelegt.

Nun wollte ich einfach über den Link weitere Datenbanken erstellen. Aber hier erscheint nur ein roter Balken, aber kein Menu.
Das gleiche erscheint auch bei allen anderen Links.

Darauf wird angezeigt:

Can't locate object method "no_menu" via package "SL::Layout::Admin" at /usr/local/src/kivitendo-erp/SL/Dispatcher/AuthHandler/Admin.pm line 26.

Das Skript, welches gemeint ist, sieht so aus:

package SL::Dispatcher::AuthHandler::Admin;

use strict;
use parent qw(Rose::Object);

use SL::Layout::Dispatcher;

sub handle {
  my ($self, %params) = @_;

  %::myconfig = User->get_default_myconfig;

  my $ok =  $::auth->is_api_token_cookie_valid;
  $ok  ||=  $::form->{'{AUTH}admin_password'} && ($::auth->authenticate_root($::form->{'{AUTH}admin_password'})            == $::auth->OK());
  $ok  ||= !$::form->{'{AUTH}admin_password'} && ($::auth->authenticate_root($::auth->get_session_value('admin_password')) == $::auth->OK());
  $ok  ||=  $params{action} eq 'login';

  $::auth->create_or_refresh_session;

  if ($ok) {
    $::auth->delete_session_value('FLASH');
    return 1;
  }

  $::request->{layout} = SL::Layout::Dispatcher->new(style => 'admin');
  $::request->layout->no_menu(1);
  $::auth->delete_session_value('admin_password');
  $::auth->punish_wrong_login;
  SL::Dispatcher::show_error('admin/adminlogin', 'password');

  return 0;
}

1;

Die betreffende Zeile ist: $:request->layout->no_menu(1);

Seit Stunden bin ich schon auf der Suche nach dem Fehler. Bei der Installation habe ich mich sehr strickt an die Anleitung gehalten.

Wer hat einen Hinweis auf dieses Problem?

Hier noch die apache2/error.log

[Wed Nov 06 16:19:33.574845 2019] [fcgid:warn] [pid 21339:tid 3050302272] [client 127.0.0.1:59962] mod_fcgid: stderr: Can't locate object method "no_menu" via package "SL::Layout::Admin" at /usr/local/src/kivitendo-erp/SL/Dispatcher/AuthHandler/Admin.pm line 26., referer: http://localhost/kivitendo-erp/controller.pl?action=Admin%2fnew_user
[Wed Nov 06 16:24:40.845799 2019] [fcgid:warn] [pid 21338:tid 2957982528] [client 127.0.0.1:60216] mod_fcgid: stderr: Can't locate object method "no_menu" via package "SL::Layout::Admin" at /usr/local/src/kivitendo-erp/SL/Dispatcher/AuthHandler/Admin.pm line 26., referer: http://localhost/kivitendo-erp/controller.pl
[Wed Nov 06 21:18:54.436522 2019] [fcgid:warn] [pid 21339:tid 3041909568] [client 127.0.0.1:43738] mod_fcgid: stderr: Can't locate object method "no_menu" via package "SL::Layout::Admin" at /usr/local/src/kivitendo-erp/SL/Dispatcher/AuthHandler/Admin.pm line 26., referer: http://localhost/kivitendo-erp/controller.pl?action=Admin%2fcreate_dataset_login
[Wed Nov 06 21:22:53.582133 2019] [fcgid:warn] [pid 21339:tid 2983160640] [client 127.0.0.1:43982] mod_fcgid: stderr: Error: Das Anlegen der Authentifizierungsdatenbank schlug fehl:<br>ERROR:  database "kivitendo_auth" already exists, referer: http://localhost/kivitendo-erp/controller.pl
[Wed Nov 06 21:23:11.438149 2019] [fcgid:warn] [pid 21338:tid 2941197120] [client 127.0.0.1:44008] mod_fcgid: stderr: Can't locate object method "no_menu" via package "SL::Layout::Admin" at /usr/local/src/kivitendo-erp/SL/Dispatcher/AuthHandler/Admin.pm line 26., referer: http://localhost/kivitendo-erp/controller.pl
[Wed Nov 06 21:29:07.604240 2019] [mpm_event:notice] [pid 21206:tid 3074864960] AH00491: caught SIGTERM, shutting down
[Thu Nov 07 10:49:05.940103 2019] [ssl:warn] [pid 1385:tid 3074803520] AH01909: RSA certificate configured for 127.0.1.1:443 does NOT include an ID which matches the server name
[Thu Nov 07 10:49:06.036962 2019] [ssl:warn] [pid 1388:tid 3074803520] AH01909: RSA certificate configured for 127.0.1.1:443 does NOT include an ID which matches the server name
[Thu Nov 07 10:49:06.038551 2019] [mpm_event:notice] [pid 1388:tid 3074803520] AH00489: Apache/2.4.7 (Ubuntu) mod_fcgid/2.3.9 OpenSSL/1.0.1f configured -- resuming normal operations
[Thu Nov 07 10:49:06.038632 2019] [core:notice] [pid 1388:tid 3074803520] AH00094: Command line: '/usr/sbin/apache2'
Gefragt von (220 Punkte)
Bearbeitet von

2 Antworten

0 Punkte

[Wed Nov 06 21:22:53.582133 2019] [fcgid:warn] [pid 21339:tid 2983160640] [client 127.0.0.1:43982] mod_fcgid: stderr: Error: Das Anlegen der Authentifizierungsdatenbank schlug fehl:
ERROR: database "kivitendo_auth" already exists, referer: http://localhost/kivitendo-erp/controller.pl

Hier wird wohl versucht nochmal eine Authentifizierungsdatenbank anzulegen, obwohl schon eine vorhanden ist

was passiert den wenn Du http://localhost/kivitendo-erp aufrufst

Werner kivitendodienstleister

Beantwortet von (5.4k Punkte)

Hallo,

vielen Dank schon einmal!
Weil die Maske nach Anlegen der Auth_DB so blieb, wie sie war habe ich das einfach noch mal gemacht. Und das schlug erwartungsgemäß fehl.
Inzwischen habe ich die erste Datenbank gelöscht und das ganze noch einmal gemacht. Mit dem Ergebnis, wo ich auch klicke, ich komme jedes mal in die Abfrage des Admin Passwortes, also auf die Anfangsseite.

Wenn ich http://localhost/kivitendo-erp aufrufe erhalte ich eine 404 Not Found The requested URL /kivitendo-erp was not found on this server. Anzeige.

http://localhost/kivitendo-erp/controller.pl
kannst du das aufrufen?
cache gelöscht apache neugestartet?

Werner kivitendodienstleister

Nein,
dann erschient das: Fehler!

Die Authentifizierungs-Datenbank kann momentan nicht erreicht werden. Entweder wurde sie noch nicht eingerichtet, oder der Datenbankserver ist momentan nicht verfügbar. Bitte wenden Sie sich an Ihren Administrator.

Wenn Sie die Authentifizierungs-Datenbank selber einrichten wollen, so melden Sie sich im Administrationsbereich an. kivitendo wird dann die Datenbank und die erforderlichen Tabellen für Sie anlegen.

Wenn ich mich http://localhost/kivitendo-erp/controller.pl?action=Admin/login aufrufe, dann erschient die Eingabemaske zum Admin-Bereich

0 Punkte

Ich bin leider immer noch nicht weiter.

Beim Einrichten habe ich das das skript, resp. die Zeilen zur Einbindung von kivitendo durch den Server in die etc/apache2/apache2.config hinein kopiert. Das ist eigentlich die Datei, die zuerst einglesen wird.

Aber kann hier der Fehler sein?

    # This is the main Apache server configuration file.  It contains the
# configuration directives that give the server its instructions.
# See http://httpd.apache.org/docs/2.4/ for detailed information about
# the directives and /usr/share/doc/apache2/README.Debian about Debian specific
# hints.
#
#
# Summary of how the Apache 2 configuration works in Debian:
# The Apache 2 web server configuration in Debian is quite different to
# upstream's suggested way to configure the web server. This is because Debian's
# default Apache2 installation attempts to make adding and removing modules,
# virtual hosts, and extra configuration directives as flexible as possible, in
# order to make automating the changes and administering the server as easy as
# possible.

# It is split into several files forming the configuration hierarchy outlined
# below, all located in the /etc/apache2/ directory:
#
#	/etc/apache2/
#	|-- apache2.conf
#	|	`--  ports.conf
#	|-- mods-enabled
#	|	|-- *.load
#	|	`-- *.conf
#	|-- conf-enabled
#	|	`-- *.conf
# 	`-- sites-enabled
#	 	`-- *.conf
#
#
# * apache2.conf is the main configuration file (this file). It puts the pieces
#   together by including all remaining configuration files when starting up the
#   web server.
#
# * ports.conf is always included from the main configuration file. It is
#   supposed to determine listening ports for incoming connections which can be
#   customized anytime.
#
# * Configuration files in the mods-enabled/, conf-enabled/ and sites-enabled/
#   directories contain particular configuration snippets which manage modules,
#   global configuration fragments, or virtual host configurations,
#   respectively.
#
#   They are activated by symlinking available configuration files from their
#   respective *-available/ counterparts. These should be managed by using our
#   helpers a2enmod/a2dismod, a2ensite/a2dissite and a2enconf/a2disconf. See
#   their respective man pages for detailed information.
#
# * The binary is called apache2. Due to the use of environment variables, in
#   the default configuration, apache2 needs to be started/stopped with
#   /etc/init.d/apache2 or apache2ctl. Calling /usr/bin/apache2 directly will not
#   work with the default configuration.


# Global configuration
#

#
# ServerRoot: The top of the directory tree under which the server's
# configuration, error, and log files are kept.
#
# NOTE!  If you intend to place this on an NFS (or otherwise network)
# mounted filesystem then please read the Mutex documentation (available
# at <URL:http://httpd.apache.org/docs/2.4/mod/core.html#mutex>);
# you will save yourself a lot of trouble.
#
# Do NOT add a slash at the end of the directory path.
#
#ServerRoot "/etc/apache2"

#
# The accept serialization lock file MUST BE STORED ON A LOCAL DISK.
#
Mutex file:${APACHE_LOCK_DIR} default

#
# PidFile: The file in which the server should record its process
# identification number when it starts.
# This needs to be set in /etc/apache2/envvars
#
PidFile ${APACHE_PID_FILE}

#
# Timeout: The number of seconds before receives and sends time out.
#
Timeout 300

#
# KeepAlive: Whether or not to allow persistent connections (more than
# one request per connection). Set to "Off" to deactivate.
#
KeepAlive On

#
# MaxKeepAliveRequests: The maximum number of requests to allow
# during a persistent connection. Set to 0 to allow an unlimited amount.
# We recommend you leave this number high, for maximum performance.
#
MaxKeepAliveRequests 100

#
# KeepAliveTimeout: Number of seconds to wait for the next request from the
# same client on the same connection.
#
KeepAliveTimeout 5


# These need to be set in /etc/apache2/envvars
User ${APACHE_RUN_USER}
Group ${APACHE_RUN_GROUP}

#
# HostnameLookups: Log the names of clients or just their IP addresses
# e.g., www.apache.org (on) or 204.62.129.132 (off).
# The default is off because it'd be overall better for the net if people
# had to knowingly turn this feature on, since enabling it means that
# each client request will result in AT LEAST one lookup request to the
# nameserver.
#
HostnameLookups Off

# ErrorLog: The location of the error log file.
# If you do not specify an ErrorLog directive within a <VirtualHost>
# container, error messages relating to that virtual host will be
# logged here.  If you *do* define an error logfile for a <VirtualHost>
# container, that host's errors will be logged there and not here.
#
ErrorLog ${APACHE_LOG_DIR}/error.log

#
# LogLevel: Control the severity of messages logged to the error_log.
# Available values: trace8, ..., trace1, debug, info, notice, warn,
# error, crit, alert, emerg.
# It is also possible to configure the log level for particular modules, e.g.
# "LogLevel info ssl:warn"
#
LogLevel warn

# Include module configuration:
IncludeOptional mods-enabled/*.load
IncludeOptional mods-enabled/*.conf

# Include list of ports to listen on
Include ports.conf


# Sets the default security model of the Apache2 HTTPD server. It does
# not allow access to the root filesystem outside of /usr/share and /var/www.
# The former is used by web applications packaged in Debian,
# the latter may be used for local directories served by the web server. If
# your system is serving content from a sub-directory in /srv you must allow
# access here, or in any related virtual host.
<Directory />
	Options FollowSymLinks
	AllowOverride None
	Require all denied
</Directory>

<Directory /usr/share>
	AllowOverride None
	Require all granted
</Directory>

<Directory /var/www/>
	Options Indexes FollowSymLinks
	AllowOverride None
	Require all granted
</Directory>

#<Directory /srv/>
#	Options Indexes FollowSymLinks
#	AllowOverride None
#	Require all granted
#</Directory>
AliasMatch ^/kivitendo-erp/[^/]+\.pl /var/www/kivitendo-erp/dispatcher.pl
Alias /kivitendo-erp/ /var/www/kivitendo-erp/

<Directory /var/www/kivitendo-erp>
 AddHandler cgi-script .pl
 Options ExecCGI Includes FollowSymlinks
</Directory>

<Directory /var/www/kivitendo-erp/users>
 Require all granted
</Directory>



# AccessFileName: The name of the file to look for in each directory
# for additional configuration directives.  See also the AllowOverride
# directive.
#
AccessFileName .htaccess

#
# The following lines prevent .htaccess and .htpasswd files from being
# viewed by Web clients.
#
<FilesMatch "^\.ht">
	Require all denied
</FilesMatch>


#
# The following directives define some format nicknames for use with
# a CustomLog directive.
#
# These deviate from the Common Log Format definitions in that they use %O
# (the actual bytes sent including headers) instead of %b (the size of the
# requested file), because the latter makes it impossible to detect partial
# requests.
#
# Note that the use of %{X-Forwarded-For}i instead of %h is not recommended.
# Use mod_remoteip instead.
#
LogFormat "%v:%p %h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" vhost_combined
LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %O" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent

# Include of directories ignores editors' and dpkg's backup files,
# see README.Debian for details.

# Include generic snippets of statements
IncludeOptional conf-enabled/*.conf

# Include the virtual host configurations:
IncludeOptional sites-enabled/*.conf

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
Beantwortet von (220 Punkte)

Da könnte der Fehler liegen
Ich habe das in Sites-*
Das ist auch eine default.conf
Hab aber gerade keine Zeit

Danke für die Antwort. Bei der Konfiguration des Servers bin ich mir wirklich nie sicher, wei ich da vorgehen soll. Ich habe die simple CGI Variante gewählt, weil SSL ist nicht notwendig.

Inzwischen bin ich einen Schritt weiter:

Zum Einen habe ich die apache2.config durch den Eintrag ServerName localhost ergänzt.

Dann bin ich die Installation noch einmal druchgegangen:

Und offenbar habe ich nicht die postgresql.conf und die pg_hba.conf nicht angepasst gehabt, wie es notwendig gewesen wäre.

In der postgresql.conf habe ich die auskommentierte Zeile listen_address localhost aktiviert und in der pg_hba.conf die Werte so gesetzt:

local   all             postgres                                peer
local   all             all                                     peer
host    all             all             127.0.0.1/32            trust
host    all             all             ::1/128                 reject

Nun komme ich in den Adminbereich und konnte also Datenbanken anlegen. Ich habe, außer der Authentifizierungsdatenbank, allerdings direkt in postgresql meine alten Datenbanken eingegeben und die vorhandenen dann über den Admin-Bereich geladen.

Dann einen Benutzer und einen Mandanten angelegt und:

Ich kriege jetzt den Benutzer nicht so angelegt, dass ich auch in diesen Bereich komme. Ich habe den schon -zig mal wieder gelöscht, neu angelegt......

Aber das scheint ein anderes Problem zu sein, oder kann das damit zusammen hängen?

Hallo
1.) fast-cgi ist fast schon notwendig weil sonst die einzelnen Aufrufe doch sehr lange dauern können, da neuauch sehr viele module dazugekommen sind.
Was heißt

allerdings direkt in postgresql meine alten Datenbanken eingegeben

Hast Du ein Backup zurückgespielt?
Wenn ja von welcher Version?

und was heißt

Ich kriege jetzt den Benutzer nicht so angelegt, dass ich auch in diesen Bereich komme

Der Mandant muss einer Datenbank zugeordnet sein, Der Benutzer muss einer Gruppe und einem Mandanten zugeordnet sein. In der Gruppe werden die Recte vergeben.
Klappt der Datenbanktest des Mandanten?

Hast Du einen Extra Datenbankbenutzer kivitendo wie in 2.5.5 der Doku beschrieben oder benutzt du den Postgressuperuser postgres wie in 2.5.4 der Doku angelegt und benutzt Du diesen? Den Superuser brauchst Du auf jedenfall.

Auf jedenfall schein deine pg_hba.conf noch nicht ganz richtig zu sein.

local all kivitendo password
host all kivitendo 127.0.0.1 255.255.255.255 password

Werner kivitendodienstleister

Auch dieses Problem ist gelöst: Ich habe bei der Einrichtung offenbar etwas durcheinander gebracht.

Den Benutzer habe ich gelöscht und durch einen anderen ersetzt.

Zwar habe ich gerade ein neues Problem mit alten Datenbanksätzen, aber dafür mach ich dann doch, wen ich nicht weiter komme eine neues Thema auf.

Unter dem Strich war, wie oben beschrieben, die Konfiguration nicht vollständig.

Kivitendo funktioniert im Prinzip jetzt.

Hallo,

die Antwort habe ich eben noch nicht gesehen.

Die pg_hba.conf werde ich mir noch einmal ansehen.

Das Andere: Ich habe noch aus lx-office meine Datenbanken gesichert. Die gleichnamige Datenbank habe ich also nicht über Kivitendo eingegeben, sondern im PostgreSQL Umfeld über das Terminal.
Blöderweise habe ich die Datenbanken nur bis postgresql 9.1 migriert. Jetzt habe ich 9.3. Allerdings müßte das funktionieren.
Dann aus dem Dump zurück gespielt, weil die mit allen Tabellen etc. ja gesichert wurden. Kivitendo hat dann versucht, die Datenbank mit den Tabellen zu überarbeiten. Bis das System hing.

Vielleicht weißt Du ja, wie ich die Anweisungen händisch erledigen kann, falls Kivitendo das nicht schafft.

Im Moment werde ich, weil eben alles hängt, die Datenbank noch einmal löschen und das Ganze von vorn.

Eigentlich wollte ich ein neues Thema dafür aufmachen, aber vielleicht geht das auch hier:

Die Datenbank habe ich nicht noch einmal gelöscht, sondern erst einmal das System wieder entsperrt, nachdem die Meldung kam, dass es ween "Wartungsarbeiten" nicht erreichbar ist.

Dann die Datenbankaktualisierung wiederholt, schon weil das nach dem Einloggen mit dem Benutzer angezeigt wurde.

Nach der Wiederholung dann erst einmal wieder in den Admin-Bereich einloge, von dort wieder zum Benutzer, der mit dem Mandanten verbunden ist, der ich die Datenbank zugeweisen habe.

Jetzt wird folgendes gemeldet:

Während der Ausführung trat eine Ausnahme auf.
Typ: undef
Information:
do_transaction() failed - get_objects() - DBD::Pg::st execute failed: ERROR: column t1.deleted does not exist
LINE 2: t1.deleted,

       at /usr/share/perl5/Rose/DB/Object/Manager.pm line 2014.

at /usr/share/perl5/Rose/Object/MakeMethods/Generic.pm line 52.

und etwas weiter unten, rot unterlegt:

Fehler!
get_objects() - DBD::Pg::st execute failed: ERROR: column t1.accounting_method does not exist
LINE 2: t1.accounting_method,

      at /usr/share/perl5/Rose/DB/Object/Manager.pm line 2014.

at bin/mozilla/login.pl line 54.

Es fehlen also Spalten.

Wie gesagt: Ich habe die Daten aus einem Datanbank-Dump geladen. Die stammen noch aus einem LX-Office System.
Die Datenbank habe ich, weil es nicht funktioniert hatte wenn ich sie direkt im Admin Bereich anlege und dort auch schon Tabellen angelegt werden, in einem Terminal in der postgres-Umgebund angelegt und dannn die Datenmank eingespielt.

Als ich mich dann einloggte, hat die ERP eine Datenbankaktualisierung initiiert, mit eben diesem Ergebnis.

Das erste Problem scheint ja gelöst- Deswegen habe ich eine neue Frage gestellt, denn das ist ein eigenes Problem.

...