Willkommen im kivitendo Forum! Hier erweitern und teilen AnwenderInnen und EntwicklerInnen ihr Wissen.

Teste kivitendo!

kivitendo Demo

kivitendo Demo mit Schweizer Kontenplan und neuem Layout

Unterstützt kivitendo mit der Basis-Subskription!

0 Punkte

Hilfe wie komme ich nun auf die stable Version 3.8.0

von (2.7k Punkte)

2 Antworten

0 Punkte

Hallo Leute habe es einfach mal wieder auf dem herkömmlichen Wege installiert (past und copy).

Nun hänge ich mal wieder bei

Fehler: Konvertierung zu PDF schlug fehl: Die Anwendung "latexmk
--pdflatex" wurde auf dem System nicht gefunden. Bitte wenden Sie sich an Ihren Administrator. at
/home/kivi/www/kivitendo/kivitendo-erp/SL/Helper/CreatePDF.pm line
101.

fest, also das drucken funzt nicht. Nutze die RB Vorlagen die ich auch gerne weiter nutzen möchte.
Der durchlauf von ./scripts/installation_check.pl -lvbringt das Ergebnis das

Your pdfx version is too old. You cannot use ZuGFeRD or modern (2018+)

anbei mal die komplette Ausgabe.

 $ ./scripts/installation_check.pl -lv              Looking for LaTeX kpsewhich ................................................. ok
Looking for LaTeX package pdfx .............................................. ok
sh: 1: latexmk: not found
Looking for pdfx version 2018 or higher ................................. NOT ok

Checking LaTeX Dependencies for Master Templates 'RB':
Looking for LaTeX document class scrartcl ................................... ok
Looking for LaTeX package colortbl .......................................... ok
Looking for LaTeX package embedfile ......................................... ok
Looking for LaTeX package eurosym ........................................... ok
Looking for LaTeX package geometry .......................................... ok
Looking for LaTeX package german ............................................ ok
Looking for LaTeX package graphicx .......................................... ok
Looking for LaTeX package hyperref .......................................... ok
Looking for LaTeX package ifthen ............................................ ok
Looking for LaTeX package inputenc .......................................... ok
Looking for LaTeX package kivitendo ......................................... ok
Looking for LaTeX package lastpage .......................................... ok
Looking for LaTeX package latexsym .......................................... ok
Looking for LaTeX package longtable ......................................... ok
Looking for LaTeX package scrpage2 ...................................... NOT ok
+------------------------------------------------------------------------------+
  LaTeX package scrpage2 could not be loaded.

  On Debian you may find the needed *.deb package with:
    apt-file search scrpage2.sty

  Maybe you need to install apt-file first by:
    aptitude install apt-file && apt-file update
+------------------------------------------------------------------------------+
Looking for LaTeX package substr ............................................ ok
Looking for LaTeX package tabularx .......................................... ok
Looking for LaTeX package textcomp .......................................... ok
Looking for LaTeX package ulem .............................................. ok
Looking for LaTeX package wallpaper ......................................... ok
Looking for LaTeX package xcolor ............................................ ok
Looking for LaTeX package xstring ........................................... ok
Looking for LaTeX package xy ................................................ ok

Checking LaTeX Dependencies for Master Templates 'Standard':
Looking for LaTeX document class scrartcl ................................... ok
Looking for LaTeX package colortbl .......................................... ok
Looking for LaTeX package embedfile ......................................... ok
Looking for LaTeX package eurosym ........................................... ok
Looking for LaTeX package fontenc ........................................... ok
Looking for LaTeX package fontspec .......................................... ok
Looking for LaTeX package geometry .......................................... ok
Looking for LaTeX package german ............................................ ok
Looking for LaTeX package graphicx .......................................... ok
Looking for LaTeX package hyperref .......................................... ok
Looking for LaTeX package iftex ............................................. ok
Looking for LaTeX package ifthen ............................................ ok
Looking for LaTeX package inputenc .......................................... ok
Looking for LaTeX package kiviletter ........................................ ok
Looking for LaTeX package kivitendo ......................................... ok
Looking for LaTeX package latexsym .......................................... ok
Looking for LaTeX package longtable ......................................... ok
Looking for LaTeX package textcomp .......................................... ok
Looking for LaTeX package transparent ....................................... ok
Looking for LaTeX package ulem .............................................. ok
Looking for LaTeX package xstring ........................................... ok

Checking LaTeX Dependencies for Master Templates 'marei':
Looking for LaTeX document class scrartcl ................................... ok
Looking for LaTeX package colortbl .......................................... ok
Looking for LaTeX package embedfile ......................................... ok
Looking for LaTeX package eurosym ........................................... ok
Looking for LaTeX package fontenc ........................................... ok
Looking for LaTeX package fontspec .......................................... ok
Looking for LaTeX package geometry .......................................... ok
Looking for LaTeX package german ............................................ ok
Looking for LaTeX package graphicx .......................................... ok
Looking for LaTeX package hyperref .......................................... ok
Looking for LaTeX package iftex ............................................. ok
Looking for LaTeX package ifthen ............................................ ok
Looking for LaTeX package inputenc .......................................... ok
Looking for LaTeX package kiviletter ........................................ ok
Looking for LaTeX package kivitendo ......................................... ok
Looking for LaTeX package latexsym .......................................... ok
Looking for LaTeX package longtable ......................................... ok
Looking for LaTeX package textcomp .......................................... ok
Looking for LaTeX package transparent ....................................... ok
Looking for LaTeX package ulem .............................................. ok
Looking for LaTeX package xstring ........................................... ok

Checking LaTeX Dependencies for Master Templates 'rev-odt':
Looking for LaTeX package embedfile ......................................... ok
Looking for LaTeX package textcomp .......................................... ok
Looking for LaTeX package ulem .............................................. ok
+------------------------------------------------------------------------------+
  Your pdfx version is too old. You cannot use ZuGFeRD or modern (2018+)
  templates. Please consider using a more recent LaTeX environment.
  Verify with:
  pdflatex --interaction=batchmode "\RequirePackage{pdfx}[2018/12/22]"
+------------------------------------------------------------------------------+

Result:
All ..................................................................... NOT ok

Und meine inheaders.tex von RB sieht wie folgt aus:

%Dokumentenklasse für DIN-Briefe auf A4
\documentclass[a4paper]{scrartcl}[10pt]

% Schriftart, Eingabelayout der Tastatur
\usepackage[utf8]{inputenc}
\usepackage[pdftex]{graphicx}
\usepackage{german}
\usepackage{ifthen}
\usepackage{longtable}
\usepackage{tabularx}
\usepackage{eurosym}
\usepackage{substr}
%\usepackage{scrpage2}
%\usepackage{scrlayer-scrpage}
\RequirePackage{scrlfile}
\ReplacePackage{scrpage2}{scrlayer-scrpage}
\usepackage{wallpaper} % Hintergrundbilder
\usepackage{xcolor,colortbl}
\usepackage{lastpage}
\usepackage{geometry}
von (2.7k Punkte)

heute mal wieder viel versucht, bisher ohne Erfolg

Mach einfach, wenn Du das nicht benötigst, das Einbetten der Zugferd-Rechnungsdaten aus.

In der Mandantenkonfiguration unter "Features" den Punkt "Verkaufsrechnungen mit Factur-X-/ZUGFeRD-Daten erzeugen" ausschalten.

Dann sollte zumindest wieder ein PDF erzeugt werden.

/Hannes

0 Punkte

Hallo Turtle,
erstmal welches Betriebssystem hast du?
Das Paket latexmk kannst Du bei debian nachinstallieren oder du passt wieder den latexpfad in der kivitendo.conf an
Also entweder

latex = latexmk --pdflatex

oder

latex = pdflatex

sollte beides gehen wobei der erste Befehl schaut ob latex wirklich 2 x interpretieren muss. Das zweite interpretiert grundsätzlich zweimal.

Welche latexversion du hat kannst du hiermit überprüfen.

pdflatex --interaction=batchmode "\RequirePackage{pdfx}[2018/12/22]"

Manchmal kann es auch in vielerlei Hinsicht wertvoll sein einen Dienstleister einzuschalten.

  • spart Zeit und Ärger
  • lernt was man machen muss und kann es so das nächste mal besser machen.
  • ...

Ansonsten kann ich auf das kivitreffen dieses Jahr hinweisen, bei dem es auch eine Adminsitratorschulung geben soll.

Beste Grüße
Werner kivitendodienstleister

Am 25.5 und 26.5.23 findet das kivitendotreffen 2023 statt. Am 26.5. dann auch Schulungen und Administration für die Entwicklung von kivitendo.

von (16.0k Punkte)

Hallo Werner,

vielen Dank, ich nutze ubuntu 22.10 als reines Serverpaket (ohne GUI).

Zur Frage:

$ pdflatex --interaction=batchmode "\RequirePackage{pdfx}[2018/12/22]"
This is pdfTeX, Version 3.141592653-2.6-1.40.24 (TeX Live 2022/Debian) (preloaded format=pdflatex)
 restricted \write18 enabled.
entering extended mode

und meiner kivitensdo.conf steht unter folgendes:

[applications]
#aqbanking = /usr/bin/aqbanking-cli
latex = latexmk --pdflatex

Hallo,
und hast du jetzt das latexmk Paket installiert sollte ja unter Ubuntu genauso gehen oder hast die Zeile in der kivitendo.conf angepasst?

Beste Grüße
Werner kivitendodienstleister

Am 25.5 und 26.5.23 findet das kivitendotreffen 2023 statt. Am 26.5. dann auch Schulungen und Administration für die Entwicklung von kivitendo.

Hallo Werner,

entschuldige habe glatt übersehen das das Paket 'latexmk', das du Vorgeschlagen hast zu installieren. Das habe ich nun explizit nachgeholt, was soll ich sagen getan und funktioniert. Vielen, vielen Dank.

Was habe ich mich doch herum geschlagen mit cpan etc. und anpassen / erneuern der vorhanden Pakete.

Ähnliche Fragen

0 Punkte
3 Antworten
Gefragt 17, Jun 2022 von turtle (2.7k Punkte)
0 Punkte
1 Antwort
Gefragt 4, Jul 2017 von turtle (2.7k Punkte)
0 Punkte
1 Antwort
Gefragt 23, Feb 2014 von puba (480 Punkte)
0 Punkte
1 Antwort
Gefragt 28, Okt 2013 von raimo (1.6k Punkte)
...