Willkommen im kivitendo Forum! Hier erweitern und teilen AnwenderInnen und EntwicklerInnen ihr Wissen.

Teste kivitendo!

kivitendo Demo

kivitendo Demo mit Schweizer Kontenplan

Geld allein macht nicht glücklich - benutzt kivitendo!

0 Punkte

Hallo, ich habe ein kleines Problem beim Drucken / Dokument erzeugen.

Unter dem Admin->Benutzer habe ich unter "Erzeuge neue Vorlage" eine neue Vorlage Datei erstellt, bei der Dropdown Leiste "Vorlage auswählen" f-tex ausgewählt (was aber beim nächsten Aufruf des Users wieder auf "German" springt).

Nun wollte ich einen Auftrag ausdrucken bzw. ein pdf erstellen, da erhalte ich jedoch eine lange Fehlermeldung, das erste ! besagt: "LaTeX Error: File `xstring.sty' not found". Da scheint er recht zu haben, denn in dem erstellten Vorlage Verzeichnis ist jene Datei nicht vorhanden. Mache ich etwas falsch, wie wäre der richtige Weg auch für die Zukunft falls Vorlagen Änderungen angeboten werden?

Gefragt von (2.3k Punkte)
wieder getaggt von

3 Antworten

+2 Punkte

Auf einem Debian/Ubuntu-System sollte xstring.sty im Paket texlive-latex-extra zu finden sein. Siehe Installationsanleitung, Kapitel 2.9 "Drucken mit Lx-Office".

Beantwortet von (12.2k Punkte)

OK danke.

apt-get install texlive-latex-base texlive-latex-extra texlive-fonts-recommended

Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Lese Status-Informationen ein... Fertig
texlive-latex-base ist schon die neueste Version.
texlive-latex-extra ist schon die neueste Version.
texlive-fonts-recommended ist schon die neueste Version.

auch # pdflatex läuft bei Aufruf in der Konsole.

Dann kann ich leider nicht weiterhelfen; vielleicht aber Wulf, wenn er das hier liest.

OK trotzdem, Danke

+2 Punkte

Unter dem Admin->Benutzer habe ich unter "Erzeuge neue Vorlage" eine
neue Vorlage Datei erstellt, bei der Dropdown Leiste "Vorlage auswählen"
f-tex ausgewählt (was aber beim nächsten Aufruf des Users wieder auf
"German" springt).

Unter Administration in der Benutzrerverwaltung gibt es zwei Felder.


Vorlagen auswählen -> f-tex
Erzeuge Vorlagen, Name -> [der neue Name fuer Dein neues Template Verzeichnis]
-> Speichern

Das danach wieder der erste Eintrag unter "Vorlagen auswählen" angezeigt
wird, ist normal und richtig, den dieses Feld Dient nur zum erstellen
Deines template Verzeichnisses.

Unter "Benutze Vorlagen" sollte allerdings
[der neue Name fuer Dein neues Template Verzeichnis]
stehen.

Nun wollte ich einen Auftrag ausdrucken bzw. ein pdf erstellen, da
erhalte ich jedoch eine lange Fehlermeldung, das erste ! besagt: "LaTeX
Error: File `xstring.sty' not found". Da scheint er recht zu haben, denn
in dem erstellten Vorlage Verzeichnis ist jene Datei nicht vorhanden.
Mache ich etwas falsch, wie wäre der richtige Weg auch für die Zukunft
falls Vorlagen Änderungen angeboten werden?

zum einen kannst Du mal ausfuehren:


scripts/installation_check.pl -lv

wenn das keine Fehler zeigt, aber beim Drucken trotzdem xstring.sty
fehlt, hast Du ein Problem mit dem kpathsea Enviroment unter Apache.
also Frage: was sagt das Script?

mbunkus hat recht mit der Paketangabe. Mach mal bitte folgendes


dpkg -L texlive-latex-extra | grep xstring.sty

da sollte folgendes zurueck kommen:


/usr/share/texmf-texlive/tex/latex/xstring/xstring.sty

wenn das der Fall ist, mache bitte mal:


sudo mktexlsr

das regeneriert noch mal die von kpathsea verwendeten Eintraege.

Grundsaetzlich klingt das als ob Deine LaTeX Umgebung nicht mehr sauber
ist. Ich wuerde dem auch je nach Ergebnis der von mir Angeregten Dinge
auch nachgehen.

Als Workaround kannst Du aber auch einfach die Datei direkt in Dein
Template Verzeichnis kopieren. Wechsel in Dein Templateverzeichnis und
fuehre folgenden Befehl aus:


wget http://mirrors.ctan.org/macros/latex/contrib/xstring/xstring.sty

(kann Dir aber passieren, dass Dir dann gleich das naechste fehlt, je
nach dem was da bei Dir im System verrutscht ist)

hoffe es hilf, ansonsten machen wir nach Deinen Antworten weiter

Beantwortet von (17.9k Punkte)

Hallo wulf, danke dir anbei so was wie ein

Ergebnisbericht:

# scripts/installation_check.pl -lv
Looking for LaTeX package xstring ....................................... NOT ok

Also wird es sehr wahrscheinlich schon daran klemmen. Alle anderen Auflistungen (jede Menge) haben ein grünes OK bekommen. Das mit der Option -lv wusste ich bis datum gar nicht, wieder etwas dazu gelernt.

# dpkg -L texlive-latex-extra | grep xstring.sty

Hier erhalte ich keine Informationen zurück. Das direkte laden via "wget" habe ich noch nicht probiert, evtl. gibt es da andere Vorschläge wie ich das LaTex Paket "xstring" irgendwie nachinstalliere.

/usr/share/texmf-texlive/tex/latex/xstring/

Dieses Verzeichnis also ab /xstring gibt es bei mir nicht, soll ich jenes anlegen und "wget" dort ausführen?

Ich würde zuerst versuchen, das Paket schlicht neu installieren zu lassen: apt-get install --reinstall texlive-latex-extra. In besagtem Verzeichnis müsste laut Paket zumindest eine xstring.sty liegen. Hier mal die Ausgabe bei mir:

[0 root@lx-office ~] dpkg -L texlive-latex-extra | grep xstring
/usr/share/texmf-texlive/tex/latex/xstring
/usr/share/texmf-texlive/tex/latex/xstring/xstring.sty
/usr/share/texmf-texlive/tex/generic/xstring
/usr/share/texmf-texlive/tex/generic/xstring/xstring.tex
[0 root@lx-office ~] ls /usr/share/texmf-texlive/tex/latex/xstring
xstring.sty

Hallo mbunkus, danke dir.

apt-get install --reinstall texlive-latex-extra

Ist ausgeführt hat eine ganze weile gebraucht, aber die abfrage

dpkg -L texlive-latex-extra | grep xstring

bleibt leer bzw. erhalte keine Infos. Auch die Script-Abfrage bleibt die gleich, wie zuvor. Auch wurde der Ordner .../xstring nicht angelegt und somit auch keine Inhalte. So wie ich das sehe benötige ich zwei files "xstring.sty" + "xstring.tex" inkl. dem Ordner "xstring". Sind da bei dir noch andere Files in diesem Ordner oder nur die zwei beiden?

Auflistungen (jede Menge) haben ein grünes OK bekommen. Das mit der
Option -lv wusste ich bis datum gar nicht, wieder etwas dazu gelernt.

-h ist immer eine Reise Wert ;)

scripts/installation_check.pl --help

Das direkte laden via "wget" habe ich noch nicht probiert, evtl.

gut so

  1. habe ich gesehen das xstring.sty selbst wieder auf xstring.tex
    referenziert, das haette also nicht geklappt.

  2. war das gedacht, falls der installations_check klappt

  3. wenn, dann lokal ins template Verzeichnis, aber nicht das System noch
    mehr durcheinander bringen als es schon ist. der von mmbunkus erwaehnte
    reinstall ist sicher ein kluger weg

schick mal bitte ein:

dpkg -l | grep texlive-latex-extra

Oh, du tippst auf Versionsnummernunterschiede? Tricky! Auf dem von mir oben genannten System ist es ein Debian Squeeze mit ii texlive-latex-extra 2009-10. Auch wenn du nicht mich, sondern turtle meintest.

Hallo wulf,

# dpkg -l | grep texlive-latex-extra
ii  texlive-latex-extra                   2007.dfsg.17-1~lenny02               TeX Live: LaTeX supplementary packages
ii  texlive-latex-extra-doc           2007.dfsg.17-1~lenny02               TeX Live: Documentation files for texlive-latex-extra

Dies liefert mir die Konsole hierauf als Info, Gruß turtle

So nun habe ich in meinem angelegten templates Ordner

wget http://mirrors.ctan.org/macros/latex/contrib/xstring/xstring.sty

ausgeführt. Wie zu Anfang richtig von wulf vermutet wäre nun die nächste Fehlermeldung im darauf folgendem Fenster "Drucken": -->! I can't find file `xstring.tex'. Könnte nun versuchen ebenfalls dieses File via wget zu laden, oder könnte das ein Faß ohne Boden werden?

Gesagt getan, habe mir das xstring.zip file heruntergeladen und die inhalte .sty + .tex ins templates Verzeichnis kopiert. leider kommt die nächste Meldung statt des Druck-Ergebnisses :

! I can't write on file `users/lx-office-printP0shio.tex.table.tex'.

+1 Punkt

>> schick mal bitte ein:
>> dpkg -l | grep texlive-latex-extra

turtle schreib:
> ii texlive-latex-extra 2007.dfsg.17-1~lenny02

ok, hier kommen wir der Sache naeher.

mbunkus schreib:
> Oh, du tippst auf Versonsnummernunterschiede? Tricky!
> Auf dem von mir oben genannten System ist es ein Debian Squeeze mit
> texlive-latex-extra 2009-10. Auch wenn du nicht mich,
> sondern turtle meintest.

hatte ich auch irgendwie verdraeng und ich habe nicht gleich geschaltet
als ich lenny las, aber:

xstring ist erst seit sqeeze in debian verfuegbar, siehe:

lenny: http://packages.debian.org/lenny/texlive-latex-extra
squeez: http://packages.debian.org/squeeze/texlive-latex-extra

turtle schreib:
> Gesagt getan, habe mir das xstring.zip file heruntergeladen und die
> inhalte .sty + .tex ins templates Verzeichnis kopiert.

das ist genau die richtige Loesung in dem Fall.
Unabhaengig vom aktuellen Problem (da ist die Loesung foellig ok)
ueberlege doch mal ob von lenny (oldstable) nicht auf squeeze (stable)
updatest.

  1. seit 2 Wochen gibt es fuer Lenny keine Sicherheitsupdates mehr.
  2. Debian ist ja immer ein bisschen lahm, aber wir steuern auf wheezy zu ..

die nächste Meldung statt des Druck-Ergebnisses :
! I can't write on file `users/lx-office-printP0shio.tex.table.tex'.

jo das ist der hier:
http://forum.lx-office.org/index.php?id=12601

gib doch bitte kurz Bescheid, wenn alles geht

Beantwortet von (17.9k Punkte)

Hallo wulf, Gold richtig. Das Drucken funktioniert.

Der Tipp inkl. Link war genau der richtige, sogar das versenden via Email scheint zu funktionieren. Das lenny eingestellt wurde ist mir auch schon aufgefallen, danke. Ich werde mich die Tage intensiv damit auseinander setzen.

Ähnliche Fragen

0 Punkte
1 Antwort
0 Punkte
1 Antwort
Gefragt 23, Okt 2015 von keviren (20 Punkte)
0 Punkte
1 Antwort
Gefragt 30, Mär 2012 von Dirk (20 Punkte)
...