Willkommen im kivitendo Forum! Hier erweitern und teilen AnwenderInnen und EntwicklerInnen ihr Wissen.

Teste kivitendo!

kivitendo Demo

kivitendo Demo mit Schweizer Kontenplan

Geld allein macht nicht glücklich - benutzt kivitendo!

0 Punkte

Hallo,

weiterhin gelingt es mir nicht, auch via kivitendo 3x heraus eine Mail zu senden. Weder mit exim noch auf die simple (smtp) Art. Bei letzterem ist im Browser zu lesen:

 send email : Net::SMTP::SSL: Bad hostname 'my.domain.eu' ...propagated at 
../SL/Mailer/SMTP.pm line 30.

Habe in der ./conf/kivitendo.conf unter der Rubrik [mail_delivery] method, host, port, security, login und password gesetzt. Jemand die zündete, funktionierende Idee?

Gefragt von (2.3k Punkte)

Habe das selbe Problem, wenn ich die Methode "smtp" einstelle.
Verwende ich stattdessen ein "sendmail", wird mir angezeigt, dass die Mailversendet ist. Kommt allerdings nicht an :(

3 Antworten

0 Punkte

Hallo Turtle, Hallo Aravon,

hatte ein ähnliches Problem welches sich eigentlich ganz schlicht gelöst hat. Mein Email Provider verlangt bei normalen SMTP-Versand keine Authentifizierung, so habe ich einfach die Felder für Login und Passwort offen gelassen. Beim Versand eines Angebotes, einer Rechnung, etc bekam ich folgende Fehlermeldung.

send email : Net::SMTP: connect: Connection refused propagated at  ../SL/Mailer/SMTP.pm line 30.

Die einfache Lösung war die Vorgänge vorher zu Speichern.

Bad Hostname

bedeutet ja nichts anderes als das der Host nicht erreichbar ist. Vielleicht einfach mal im Terminal die die einzelnen zur Verfügung gestellten Ports anpingen oder es mit der direkten IP-Adresse des Mailservers Probieren.

Bei SSL Versand hängt es wieder von eurem Provider ab, viele verwenden hier einen speziellen Host, vielleicht mal beim Provider anfragen. Außerdem wir ein Sicherheitszertifikat vorausgesetzt, welches normalerweise beim ersten Abruf des Mailklienten auf dessen Maschine hinterlegt wird.

Hoffe ich konnte euch weiterhelfen!?

Beantwortet von (400 Punkte)

Hallo Colorit,

danke für deine Antwort. Ja mit dem zuerst Speichen und dann mit der jeweiligen Client- E-Mail-Anwendung als Anhang absenden, nutze ich auch. Aber ich dachte wenn es aus der Server-Anwendung kivitendo möglich ist, erspart man sich doch ein bis zwei Schritte.

Habe es heute nochmals versucht eine Mail direkt (Auftragsbestätigung -> E-Mail-Button) abzusenden. Nun erhalte ich folgende Meldung: send email : Can't locate Authen/SASL.pm in @INC (@INC contains .... Habe versucht via cpan> install SASL leider funktionierte dies irgendwie nicht richtig.

Warum nun die andere Meldung, dies kann ich mir nur mit dem Browser Cache erklären. Aber evtl. kann man dieses Problem dennoch in den Griff bekommen, hoffe ich zumindest?

Probier es mal mit:

$ perl -MCPAN -e shell 
cpan> install Authen::SASL

in der PERL Shell oder:

$ sudo perl -MCPAN -e "install Authen::SASL"

als normaler beutzer.

Vielen Dank, der install hat nun funktioniert, entschied mich für den ersten Vorschlag.

Habe nun wieder eine andere Meldung erhalten:

send email : auth(username, password) 
  at /usr/share/perl/5.10/Net/SMTP.pm line 130.

Oder soll ich den Browser und / oder Webserver neu starten,
oder muss ich bei dem gerade installierten etwas anpassen?

Hab mal in die SMTP.pm reingeschaut, die besagte Zeile sagt eigentlich nur aus, dass das Script den Vorgang abbrechen soll wenn keine ausreichenden Anmeldeinformationen vorhanden sind. Nochmal Prüfen ob alle angaben Korrekt sind, den Webserver neu starten und mal den Cache lösdchen kann nicht schaden.

In der Regel muss man bei PERL-Modulen nichts ändern, wäre nicht Sinn und Zweck. Die Anpassungen sind nur in den Applikations notwendig, die auf das Script zurückgreifen.

Ist "sendmail" Installiert?

ok sendmail war nicht installiert, habe ich soeben installiert, Danke für den Tipp.

Neben dem automatischen entfernen der exim Pakete,
rauschte eine ganze Menge an Text, die Konsolen runter.
Derzeit reboot'e ich den Webserver.

Bin schon ganz gespannt der Dinge die da kommen, ich werde hier berichten,
hoffe das es ein Erfolgs-Bericht wird.

Nachtrag: Nee leider geht das Elend weiter,
Browser-Cache geleert und nun erhalte ich wieder jene Meldung:

send email : Net::SMTP::SSL: Bad hostname ...

Hm.. eine schleife ;-)

hab mal etwas nachgelesen... scheint ein Problem des Email-Providers zu sein, schon mal mit einem anderen Probiert?

Danke für deine Mühen und nein, habe es noch nicht mit einem anderen Provider versucht.

Ich werde 'wulf's' Vorschlag morgen probieren.

0 Punkte

ok sendmail war nicht installiert, habe ich soeben installiert, Danke für den Tipp.

Es gibt einen Spruch:

  • "wer nicht einmal in seinem Leben sendmail konfiguriert hat ist kein richtiger Admin"

der kommt daher, dass die Sendmailkonfiguration alles andere als ein Spass ist. Sendmail hat auch heute keine Bedeutung mehr auch wenn es noch weiterentwickelt wird. Allerdings ist es ein "quasi-Standard" und alle MTAs stellen einen Sendmailaufruf zur Verfuegung.

Natuerlich hattest Du /usr/bin/sendmail auf dem System, das kam halt von exim4.
Ich fuerchte Du kommst gerade vom Regen in die Traufe.

Schmeiss Sendmail wieder runter und nimm was vernuenftiges, kann auch postfix sein. Allerdins ist exim4 wie erwaehnt einfach super fuer gaenau diese Aufgabe. Ist auch nicht ohne grund in der light version der standard MTA bei Debian.

Mach Dir erstmal klar, ueber welchen Smarthost Du versenden willst, am besten schaust Du die Einstellungen in Deinem Mailclient ab:

  • severname
  • port
  • tls oder ssl (ja das ist was anderes)
  • auth (falls erforderlich in Form von Benutzername und Passwort)
  1. schmeiss sendmail runter
    aptitude purge sendmail

  2. raeum die Ueberbleibsel Deiner alten exim-versuche auf
    aptitude purge exim4-daemon-light
    falls /etc/exim4 nicht geloescht wird:
    mv /etc/exim4 /etc/exim4_old

  3. installiere exim4
    aptitude install exim4-daemon-light
    Dabei beantwortest Du die Fragen folgendermassen

 1. type (3. Antwort):  mail sent by smarthost; no local mail
 2. system-mail-name: (Dein hostname)
 3. IP-addresses to listen: 127.0.0.1 (also localhost)
 4. Other destinations for which mail is accepted: <leer>
 5. visible domainnaim: (Dein Hostname)
 6. IP address or host name of the outgoing smarthost: (der Servername, also die Antwort auf meine Frage ganz oben)
 7. Keep number of DNS-queries minimal (Dial-on-Demand)?: no (also den default lassen)
     (Wenn Du 1-7 spaeter noch mal durchlauffen lassen willst, musst Du
    `dpkg-reconfigure exim4-config`
     aufrufen)
  1. konfiguriere die authentifizierung in der Datei
    /etc/exim4/passwd.client
    da steht drin wie es geht, Du haengst einfach Servername,Benutzername,Passwort mit ":" getrennt aneinander.

  2. Tests (alle als root)
    1. routing pruefen

         `exim4 -bv -v foo@bar.de`
         sollte Dir anzeigen dass der Smarthost verwendet wird
    
    1. Test
      echo foo | mail -s "das ist mein erster test" turtle@domain.de
      das ist die erste wirklich verschickte Mail, kontoliere das mit
      exigrep turtle /var/log/exim4/mainlog
      da kannst Du sehen, ob das sauber zugestellt wurde. Da siehst Du ach ob tls verwendet wurde usw.
      Das ist aber noch keine garantie ob versand an externe domains geht!
    2. hier wird es spannend ob Dein auth geht.
      echo foo | mail -s "test extern" kivitendo@coulmann.de
      auch das kontrollierst Du
      exigrep kivitendo /var/log/exim4/mainlog

wenn das nicht geht noch mal schritt fuer schritt durchgehen.
Wenn das geht, geht auch kivitendo, wenn Du es auf sendmail-Versand stellst.

ist natuerlich quack, dass ich das hier hintippe denn das steht alles bei Dir auf Platte:
/usr/share/doc/exim4-daemon-light/README.Debian.gz

* 2.1.1.1.3. mail sent by smarthost; no local mail
* 2.1.1.2. System mail name
* 2.1.1.3. IP addresses to listen on for incoming SMTP connections
* 2.1.1.4. Other destinations for which mail is accepted
* 2.1.1.7. IP address or host name of the outgoing smarthost
* 2.1.1.10. Keep number of DNS queries minimal (Dial-on-Demand)
* 2.3.1. Using Exim as SMTP-AUTH client

viel Erfolg!

Beantwortet von (17.9k Punkte)

Hallo wulf,
Danke für Deine Bemühungen. :) Aber leider hab ich es nicht geschafft exim4 zu konfigurieren. Belamm immer wieder den Fehler, den turtle auch hat. Nach etwas über 2 Tagen habe ich dann doch mal Postfix installiert und nun läuft es.

Nun habe ich zwar ein Problem mit den Mails, die rein kommen, aber das ist hier o.t.

Wollte aber trotzdem ein Danke für deine Bemühungen hierlassaen..

Schönes Wochenende

Aravon

schade.

Ist nicht boese gemeint, aber da stimmt mit Euren Settings oder den Smarthosts was nicht.
Aber ich verstehe dass man als ungeuebter vor lauter Wald die Baume nicht sieht.
Fuer einen Admin mit Erfahrung ist das in sehr kurzer Zeit erledigt.

Ich weiss, das wird hier nicht gerene gelesen, aber manchmal ist Support einkaufen einfach sinnvoll.

Hallo wulf,
nein ich nehme Dir das nicht übel. Und sicherlich ist mir klar, das mit den Einstellungen etwas nicht stimmte, sonst hääte ich exim4 ans Laufen gebracht. Ich widerspreche Dir auch nicht, dass man manchmal auch mal einen Support einkaufen sollte, wenn alle Wege in Sackgassen führen. Da ich nun auf Postfix umgestiegen bin, war ein letzter Versuch, bevor ich eben diesen Schritt gehen wollte.
Mir ging es aber im letzten Post darum, mit zu teilen, wie der Stand der Dinge bei mir ist, und mich für Deinen Einsatz zu bedanken.
Ich hoffe Du bist mir nicht böse darüber, dass ich nach über zwei Tagen einen anderen Weg versucht habe. Aber bei mir läuft kivitendo im Moment (noch) in der Einrichtungphase und soll bald meine alte WAWI(JTL) ersetzen, da ich mit kivitendo wesentlich mehr Möglichkeiten habe.

Trotzdem ein schönes WE.

Ich hoffe Du bist mir nicht böse

alles gut, ca 50 gut bezahlte stellenweise extrem komplexe exim Konfigurationen haben das hier querfinanziert ;)

mir faellt hier noch was ein, was Euch eventuell auf den Fuss faellt:
(mit Zugriff auf den Host und entsprechenden Infos, haette man das gleich gesehen)

wenn der Smarthost kein tls anbietet, versucht exim4 keine Authentifizierung solange man ihm nicht sagt "meine Passwoerter sind mir egal!". Das ist auch vernuenftig. (Siehe den Debian spezifischen Parameter AUTH_CLIENT_ALLOW_NOTLS_PASSWORDS)

hier noch ein paar Hinweise dazu:
* wenn man wissen will, was der smarthost tut (z.B. ob er tls anbietet), und die authentifizierung testen will verwendet man

`telnet` und oder `openssl s_client`
  • wenn man genau sehen will wo das Problem beim exim-versand liegt und es in der mainlog nicht findet, kann man dinge tun wie
    echo test | /usr/sbin/sendmail -d-all+transport test@adresse.de
    Da wuerde man sehen, ob ein auth ueberhaupt versucht wird oder nicht und wie das Ergebnis ist
0 Punkte

Hinweis: Wenn jemann das Problem mit BCC E-Mails haben sollte, siehe hier.

Beantwortet von (180 Punkte)

Ähnliche Fragen

0 Punkte
1 Antwort
Gefragt 15, Mai 2013 von Track1991 (180 Punkte)
0 Punkte
1 Antwort
Gefragt 5, Jan 2013 von aravon (270 Punkte)
0 Punkte
1 Antwort
Gefragt 4 Aug von turtle (2.3k Punkte)
0 Punkte
1 Antwort
Gefragt 23, Jun 2012 von hexvent (410 Punkte)
0 Punkte
1 Antwort
Gefragt 4 Aug von turtle (2.3k Punkte)
...