Willkommen im kivitendo Forum! Hier erweitern und teilen AnwenderInnen und EntwicklerInnen ihr Wissen.

Teste kivitendo!

kivitendo Demo

kivitendo Demo mit Schweizer Kontenplan und neuem Layout

Geld allein macht nicht glücklich - benutzt kivitendo!

0 Punkte

Hallo

Ich bin von der Version 2.6.0 dabei auf die Version 3.0 umzusteigen. Dabei ist mir aufgefallen das in den Zahlungsbedingungen bei 2.6.0 die Variable <%total%> korrekt mit zwei Nachkommstellen gesetzt wird aber das in der 3.0 mögliche Nullen am Ende einfach unterschlagen werden.

Habe ich was übersehen?

Danke

Gefragt von (330 Punkte)

1 Antwort

0 Punkte

ich habe das gerade noch mal probiert und kann das in der stable 3.0.0 nicht nachvollziehen.

Seit 2.7 gibt es die Moeglichkeit unformatierte Zahlen in das Templatesystem zu reichen, siehe:
https://demo.kivitendo.de/beta/doc/html/ch03s02.html#dokumentenvorlagen-und-variablen.variablen-ausgeben

Ich bekomme bei <%total%> den eingestellten dezimaltrenner und 2 Nachkommastellen (auch wenn diese ,00 sind)
Ich bekomme bei <%total NOFORMAT%> immer einen Punkt als dezimaltrenner und es wird nicht gerundet, bzw auch keine 0 angehaengt.
Also alles wie es sein soll. Ich vermute es liegt an Deinen Vorlagen.

Ich persoenlich halte das formatieren fuer eine Aufgabe des Dokumentsystems.

Beantwortet von (17.9k Punkte)

Meine Zahlungsbedingung lautet z.B.

 Bitte überweisen Sie den Rechnungsbetrag in Höhe von <%total%> <%currency%>
 ohne Abzüge bis zum <%netto_date%> auf das angegebene Konto.
 Bei sofortiger Zahlung können Sie 3% (<%skonto_amount%> <%currency%>) Skonto
 vom Rechnungsbetrag abziehen.

und im Template wird nur o.g. <%payment_terms%> ausgegeben. Das bringt genau diesen Effekt.

Andererseits <%total%> direkt im Template zeigt den Betrag korrekt an.

fragend ...

Meine Zahlungsbedingung lautet z.B.

ok, da kommen wir der Sache naeher. Die Variablen im Zahlungssystem sind losgeloest von denen im Dokumentsystem.
Die Substitution wird vorher schon gemacht, das ganze kommt dann (wie Du schon richtig sagst) als <%payment_terms%> an.

muss ich noch schauen, ob wir da einen Fehler haben.

>> Dabei ist mir aufgefallen das in den Zahlungsbedingungen bei 2.6.0 die Variable <%total%> .... das in der 3.0 mögliche Nullen am Ende einfach unterschlagen werden.

muss ich noch schauen, ob wir da einen Fehler haben.

Also mein System (3.0.0) verhaellt sich auch in den Zahlungsbedingungen da korrekt (mit 2 Nachkommastellen auch wenn dies 0 sind)
Sorry das ich das erst missverstanden habe, Du hattest im Betreff Dich ja eindeutig auf peyment_terms bezogen.

Nur der Vollstaendigkeit halber: in den Zahlungsbedingungen kann man die erwaehnten Optionen ( z.B. NOFORMAT) nicht verwenden.

Sooooooooo

nach einer weiteren Testinstallation und viel experimentieren nun des Rätsels Lösung.

In den Spracheinstellungen (Vorlagenkürzel für Templates) habe ich als Zahlenformat 1000,00 angegeben. Dies insbesondere damit numprint in den Templates keinen Fehler erzeugt.

In meinen persönlichen Einstellungen habe (hatte) ich als Zahlenformat 1.000,00 eingerichtet. Genau damit wurden die Nullen in den Nachkommastellen wie oben beschrieben unterschlagen.

Wenn ich jetzt meine Einstellungen auf 1000,00 ändere habe ich auch wieder die Nullen am Ende der Nachkommastellen.

Ich kann nun leider nicht beurteilen ob das die alleinige Ursache ist bzw. wo der ursprüngliche Grund für dieses Verhalten liegt.

In den Spracheinstellungen (Vorlagenkürzel für Templates) habe ich als Zahlenformat 1000,00 angegeben. Dies insbesondere damit numprint in den Templates keinen Fehler erzeugt.

bezueglich der LaTeX Templates wuerde ich Dir empfehlen Zahlen mit der Option NOFORMAT einzubinden, dann bist Du das Problem los und kannst numprint auf . als dezimaltrenner einstellen egal welches Format in Kivi gewaehlt ist.
Das ging in 2.6 noch nicht, ist aber ein grosser Vorteil.

Ähnliche Fragen

0 Punkte
1 Antwort
0 Punkte
3 Antworten
0 Punkte
2 Antworten
Gefragt 23, Jul 2013 von Jenny (130 Punkte)
0 Punkte
1 Antwort
...