Willkommen im kivitendo Forum! Hier erweitern und teilen AnwenderInnen und EntwicklerInnen ihr Wissen.

Teste kivitendo!

kivitendo Demo

kivitendo Demo mit Schweizer Kontenplan und neuem Layout

Geld allein macht nicht glücklich - benutzt kivitendo!

0 Punkte

Hallo,
nach der Installation der Version 3.1.0 aus dem Git Repository
und der Bearbeitung der kivitendo.conf
erhalte ich folgende Fehlermeldung:

Während der Ausführung trat eine Ausnahme auf.
Typ: undef
Information:

get_objects() - DBD::Pg::st execute failed: FEHLER: Relation »auth.clients« existiert nicht
LINE 11: auth.clients t1

       ^ at /usr/share/perl5/Rose/DB/Object/Manager.pm line 2014.

at /var/www/kivitendo-erp/SL/Controller/LoginScreen.pm line 168.

Was kann hier falsch gemacht worden sein?
Wie komme ich hier weiter?

Gruß
Armin Barth

von (480 Punkte)

1 Antwort

0 Punkte

Hallo Armin,

du hast vermutlich eine alte Authentifizierungsdatenbank aus einer bestehenden Installation übernommen. Ich hatte hier eben den exakt gleicher Fehler bei mir in einer frischen Installation. Hatte versehentlich release-3.0.0rc1 ausgecheckt und damit die Auth-Datenbank frisch angelegt. Nachdem ich dann auf release-3.1.0rc1 gewechselt hatte, hagelte es dieselbe Fehlermeldung, wie bei dir.

Also einfach die alte Auth-DB löschen und neu anlegen lassen. Bei mir unter Ubuntu 12.04:
root:~# service postgresql stop
root:~# su -c "dropdb deine-Auth-DB" postgres
root:~# service postgresql start

Danach Kivitendo im Browser aufrufen, und der Assistent zur Anlage der Auth-DB sollte erscheinen. Wegen der neuen Mandantenfähigkeit etwas komplexer, aber du wirst dich schon durchfrühstücken.

Gruß Raimo

Hier noch ein freundliches P.S. nach Bonn (Ich weiß, gehört nicht hierher, aber ich will ins Bett :)

Das ist mir aufgefallen:
- Typo bei "Mandanten bearbeiten" --> Datebankbenutzer und -passwort
- Typo bei "kivitendo Administration" --> Es wurden noch keine Benutzer anleget.
- Die Meldung "mkdir webdav: Permission denied at /var/www/lxo/SL/DB/AuthClient.pm line 105" ätzt und meint eigentlich "Anlegen des Ordners "webdav" im Kivitendo-Wurzelverzeichnis fehlgeschlagen"
- Die Installation ist keine wirklich freundvolle Erfahrung, aber das wißt ihr sicher selbst.

Danke für die viele Arbeit an die Entwickler!

von (1.6k Punkte)

Hallo Raimo,
danke für deine schnelle Antwort. Leider funktioniert deine Vorgehensweise so noch nicht bei mir.
Da wir hier ein Produktiv-System haben, an dem jeden Tag 6 Mitarbeiter arbeiten, muss ich die alte 3.00- Version weiter laufen lassen.
Ich habe nach deinem Hinweis eine neue Datenbank für das "kiviauth" für die Benutzer Authenzifiezierung angelegt und für meinen Datenbesatand eine neue Datenbank "gesch2014"
In der Datei "kivitendo.conf" habe ich die neue Datenbank "kiviauth" eingetragen.

Wenn ich nun die Version 3.1.0 -rc1 mit admin.pl aufrufe, erhalte ich folgende Anzeige in der 2. Zeile:
Datenbankaktualisierung (lxauth) -- Das war meine bisherige Authentifizierungsdatenbank.

Weiterhin will die neue Version 3.1.0-rc1 in der Mandentenverwaltung meine bisherige Datenbank "gesch2013"
verwenden.

Wie kann ich hier beide Syteme trennen?
Warum nimmt die Version 3.1.0-rc1 nicht die in der kivitendo.conf vorgegebene Datenbank "kiviauth"

Gruß
Armin

Hallo Arnim,

ich habe das hier eben mal nachgestellt und einen Bugreport erstellt.

https://trac.kivitendo.de/ticket/2455#ticket

Grüße Raimo

Mehrere Kivitendo-Installationen nebeneinander geht bei mir so:

  • kivitendo-Ordner z.B. nach /opt/test_kivi kopieren
  • In /etc/apache2/sites-enabled/000-default (o.ä, ich nutze hier Ubuntu) folgendes hinzufügen:

    AddHandler cgi-script .pl
    Alias /test-kivi/ /opt/test_kivi
    
    <Directory /opt/test_kivi>
     Options ExecCGI Includes FollowSymlinks
    </Directory>
  • in /opt/test_kivi/config/kivitendo.conf anderen Authentifizierungs-DB Namen eintragen, die wird ggf. beim nächsten Aufruf von Kivitendo neu erstellt. Alternativ eine alte Auth-DB importieren.
  • root:~# service apache2 restart
  • http://mein.kivitendo.server/test_kivi/

Hi Raimo,
die beiden Typos sind korrigiert.

Über den Webdav-Ordner stolper ich auch immer mal wieder, darauf wird in der Doku aber auch explizit hingewiesen: https://demo.kivitendo.de/doc/html/ch02s03.html

Hallo Jan,

prima, das war fix! Warum gibt´s eigentlich keinen leeren Ordner "webdav"? Oder alternativ eine aussagekräftigere Fehlermeldung? Wenn du schon drüber stolperst :)

@Armin: Falls noch nicht gesehen, die Fehlermeldung ist offensichtlich so beabsichtigt. Details und Problemlösung hier: https://trac.kivitendo.de/ticket/2455#ticket

Grüße Raimo

Hallo Jan, hallo Raimo,

danke für eure schnelle Hilfe und auch die Hinweise.
Offensichtlich gibt es noch ein Problem bei der Bennenung der Verzeichnisse für Kivitendo.
Ich konnte dank eurer Hinweise mein Problem mit der Umbennung wie folgt beheben:
Bei mir liegen die unterschiedlichen Versionen unter /var/www
bisher: kivitendo300, kivitendo-erp-old, kivitendo-erp
Nach der Umbenennung in: kivi300, kiviold und kivi310 sowie der Anpassung der
Aufruf-Dateien unter /etc/apache2/config.d/ nach obigem Muster,
wie bei Raimo, wurde die richtige Autentifikationsdatei beim Programmstart verwendet.
Die Fehlermeldung war weg.

Wahrschinlich erkennt Kivitendo 3.1.0 den Unterschied zwischen "kivitendo-erp-old" und "kivitendo-erp" nicht.

Gruß
Armin

Ähnliche Fragen

0 Punkte
1 Antwort
Gefragt 28, Okt 2013 von raimo (1.6k Punkte)
0 Punkte
2 Antworten
0 Punkte
1 Antwort
Gefragt 21, Feb 2014 von grichardson (16.8k Punkte)
0 Punkte
1 Antwort
Gefragt 8, Jan 2018 von sisqonrw (2.0k Punkte)
0 Punkte
2 Antworten
Gefragt 28, Mai 2015 von Schnoor (70 Punkte)
...