Willkommen im kivitendo Forum! Hier erweitern und teilen AnwenderInnen und EntwicklerInnen ihr Wissen.

Teste kivitendo!

kivitendo Demo

kivitendo Demo mit Schweizer Kontenplan

Geld allein macht nicht glücklich - benutzt kivitendo!

0 Punkte

Hallo an alle.

ich habe Lx Office 2.6.3 aus deb Packet installiert und arbeite seit längerem damit.
Jetzt habe ich beschlossen einen Update auf Kivitendo 3.1.0 durch zu führen.

als erstes habe ich die Datenbank gesichert und eine Ubuntu 12.04 auf Virtualbox installiert.

Nach Anleitung auch den Server und Kivitendo 2.7 eingerichtet.

jetzt kommt erstmal eine Frage. Wie kann ich folgende Pakete Installieren?

Checking Developer Modules:
Looking for Devel::REPL ................................................. NOT ok
Looking for Moose::Role ................................................. NOT ok
Looking for Perl::Tags .................................................. NOT ok
Looking for Test::Deep .................................................. NOT ok
Looking for GD 2.00 ..................................................... NOT ok

ohne dieser Module erhalte ich eine Fehlermeldung 500 Internal Server Error

kann mir jemand helfen?

geschlossen mit Kommentar: Update war mit hilfe von Linet erfolgreich
Gefragt von (100 Punkte)
geschlossen von

5 Antworten

0 Punkte

lass das Script mal mit -v laufen, dann bekommst Du die Info zur Installation also

 ./scripts/installation_check.pl -v
Beantwortet von (17.9k Punkte)

Folgendes meldet mir ./scripts/Installation_check.pl -a

root@ubuntu:/var/www/kivitendo-erp# ./scripts/installation_check.pl -a

Checking Required Modules:
Looking for parent ....................................................... 0.225
Looking for Archive::Zip 1.16 ............................................. 1.30
Looking for Config::Std .................................................... 0.9
Looking for DateTime ...................................................... 0.70
Looking for DBI 1.50 ..................................................... 1.616
Looking for DBD::Pg 1.49 ................................................ 2.19.0
Looking for Email::Address ............................................... 1.892
Looking for FCGI .......................................................... 0.74
Looking for JSON .......................................................... 2.53
Looking for List::MoreUtils 0.21 .......................................... 0.33
Looking for Params::Validate .............................................. 0.97
Looking for PDF::API2 2.000 .............................................. 2.019
Looking for Rose::Object ................................................. 0.859
Looking for Rose::DB ..................................................... 0.763
Looking for Rose::DB::Object ............................................. 0.797
Looking for String::ShellQuote 1.01 ....................................... 1.03
Looking for Sort::Naturally ............................................... 1.02
Looking for Template 2.18 ................................................. 2.22
Looking for Text::CSV_XS 0.23 ............................................. 0.85
Looking for Text::Iconv 1.2 ................................................ 1.7
Looking for URI 1.35 ...................................................... 1.59
Looking for XML::Writer 0.602 ............................................ 0.612
Looking for YAML 0.62 ..................................................... 0.62

Checking Optional Modules:
Looking for Digest::SHA ................................................... 5.61

Checking Developer Modules:
Looking for Devel::REPL ................................................. NOT ok
Looking for Moose::Role ................................................. NOT ok
Looking for Perl::Tags .................................................. NOT ok
Looking for LaTeX kpsewhich ................................................. ok

Checking LaTeX Dependencies for Master Templates 'Default':
Looking for LaTeX document class scrartcl ................................... ok
Looking for LaTeX package a4 ................................................ ok
Looking for LaTeX package babel ............................................. ok
Looking for LaTeX package german ............................................ ok
Looking for LaTeX package graphicx .......................................... ok
Looking for LaTeX package inputenc .......................................... ok
Looking for LaTeX package tabularx .......................................... ok
Looking for LaTeX package times ............................................. ok
Looking for LaTeX package xy ................................................ ok

Checking LaTeX Dependencies for Master Templates 'French':
Looking for LaTeX document class scrartcl ................................... ok
Looking for LaTeX package a4 ................................................ ok
Looking for LaTeX package babel ............................................. ok
Looking for LaTeX package german ............................................ ok
Looking for LaTeX package graphicx .......................................... ok
Looking for LaTeX package inputenc .......................................... ok
Looking for LaTeX package tabularx .......................................... ok
Looking for LaTeX package times ............................................. ok
Looking for LaTeX package xy ................................................ ok

Checking LaTeX Dependencies for Master Templates 'German':
Looking for LaTeX document class scrartcl ................................... ok
Looking for LaTeX package a4 ................................................ ok
Looking for LaTeX package babel ............................................. ok
Looking for LaTeX package eso-pic ........................................... ok
Looking for LaTeX package eurosym ........................................... ok
Looking for LaTeX package german ............................................ ok
Looking for LaTeX package graphicx .......................................... ok
Looking for LaTeX package ifthen ............................................ ok
Looking for LaTeX package inputenc .......................................... ok
Looking for LaTeX package longtable ......................................... ok
Looking for LaTeX package tabularx .......................................... ok
Looking for LaTeX package times ............................................. ok
Looking for LaTeX package xspace ............................................ ok
Looking for LaTeX package xy ................................................ ok

Checking LaTeX Dependencies for Master Templates 'RB':
Looking for LaTeX document class scrartcl ................................... ok
Looking for LaTeX package a4 ................................................ ok
Looking for LaTeX package babel ............................................. ok
Looking for LaTeX package colortbl .......................................... ok
Looking for LaTeX package eurosym ........................................... ok
Looking for LaTeX package geometry .......................................... ok
Looking for LaTeX package german ............................................ ok
Looking for LaTeX package graphicx .......................................... ok
Looking for LaTeX package ifthen ............................................ ok
Looking for LaTeX package inputenc .......................................... ok
Looking for LaTeX package lastpage .......................................... ok
Looking for LaTeX package longtable ......................................... ok
Looking for LaTeX package scrpage2 .......................................... ok
Looking for LaTeX package substr ............................................ ok
Looking for LaTeX package tabularx .......................................... ok
Looking for LaTeX package times ............................................. ok
Looking for LaTeX package wallpaper ......................................... ok
Looking for LaTeX package xcolor ............................................ ok
Looking for LaTeX package xy ................................................ ok

Checking LaTeX Dependencies for Master Templates 'Service':
Looking for LaTeX document class scrartcl ................................... ok
Looking for LaTeX package a4 ................................................ ok
Looking for LaTeX package babel ............................................. ok
Looking for LaTeX package german ............................................ ok
Looking for LaTeX package graphicx .......................................... ok
Looking for LaTeX package inputenc .......................................... ok
Looking for LaTeX package tabularx .......................................... ok
Looking for LaTeX package times ............................................. ok
Looking for LaTeX package xy ................................................ ok

Checking LaTeX Dependencies for Master Templates 'f-tex':
Looking for LaTeX document class scrartcl ................................... ok
Looking for LaTeX document class scrlttr2 ................................... ok
Looking for LaTeX package a4 ................................................ ok
Looking for LaTeX package babel ............................................. ok
Looking for LaTeX package booktabs .......................................... ok
Looking for LaTeX package calc .............................................. ok
Looking for LaTeX package etex .............................................. ok
Looking for LaTeX package eurosym ........................................... ok
Looking for LaTeX package filecontents ...................................... ok
Looking for LaTeX package fltpoint .......................................... ok
Looking for LaTeX package german ............................................ ok
Looking for LaTeX package graphicx .......................................... ok
Looking for LaTeX package ifpdf ............................................. ok
Looking for LaTeX package inputenc .......................................... ok
Looking for LaTeX package lastpage .......................................... ok
Looking for LaTeX package lmodern ........................................... ok
Looking for LaTeX package longtable ......................................... ok
Looking for LaTeX package ltxtable .......................................... ok
Looking for LaTeX package ngerman ........................................... ok
Looking for LaTeX package numprint .......................................... ok
Looking for LaTeX package tabularx .......................................... ok
Looking for LaTeX package textcomp .......................................... ok
Looking for LaTeX package times ............................................. ok
Looking for LaTeX package watermark ......................................... ok
Looking for LaTeX package xcolor ............................................ ok
Looking for LaTeX package xifthen ........................................... ok
Looking for LaTeX package xstring ........................................... ok
Looking for LaTeX package xy ................................................ ok
Looking for LaTeX package zref .............................................. ok
Looking for LaTeX package zwischensumme ..................................... ok

0 Punkte

Wenn du das GD Modul benötigst heißt das, daß du versuchst die aktuelle Unstable zu installieren, nicht die offizielle 3.1.0. Nur so als Hinweis, falls das nicht Absicht ist.

Eins der benötigten Module für die Unstable (ich weiß gerade nicht mehr welches) gibt es für Ubuntu auch nicht als Deb Paket, sondern das muß man per CPAN installieren.

Beantwortet von (16.3k Punkte)

Hallo,

erstmal Danke für die Unterstützung.
Leider habe ich es immer noch nicht am laufen.
Hier ist Log des Appache

[Fri Jun 20 18:56:17 2014] [error] [client 192.168.178.40] Could not load SL::DB::Order - Attempt to reload SL/DB/Chart.pm aborted.
[Fri Jun 20 18:56:17 2014] [error] [client 192.168.178.40] Compilation failed in require at SL/DB/Invoice.pm line 19.
[Fri Jun 20 18:56:17 2014] [error] [client 192.168.178.40] BEGIN failed--compilation aborted at SL/DB/Invoice.pm line 19.
[Fri Jun 20 18:56:17 2014] [error] [client 192.168.178.40] Compilation failed in require at SL/DB/Order.pm line 12.
[Fri Jun 20 18:56:17 2014] [error] [client 192.168.178.40] BEGIN failed--compilation aborted at SL/DB/Order.pm line 12.
[Fri Jun 20 18:56:17 2014] [error] [client 192.168.178.40] Compilation failed in require at (eval 1037) line 2.
[Fri Jun 20 18:56:17 2014] [error] [client 192.168.178.40] at /usr/share/perl5/Rose/DB/Object/Metadata.pm line 2063
[Fri Jun 20 18:56:17 2014] [error] [client 192.168.178.40] \tRose::DB::Object::Metadata::make_foreign_key_methods('SL::DB::Helper::Metadata=HASH(0x979e538)') called $
[Fri Jun 20 18:56:17 2014] [error] [client 192.168.178.40] \tRose::DB::Object::Metadata::make_methods('SL::DB::Helper::Metadata=HASH(0x979e538)') called at /usr/shar$
[Fri Jun 20 18:56:17 2014] [error] [client 192.168.178.40] \tRose::DB::Object::Metadata::initialize('SL::DB::Helper::Metadata=HASH(0x979e538)') called at SL/DB/Helpe$
[Fri Jun 20 18:56:17 2014] [error] [client 192.168.178.40] \tSL::DB::Helper::Metadata::initialize('SL::DB::Helper::Metadata=HASH(0x979e538)') called at /usr/share/pe$
[Fri Jun 20 18:56:17 2014] [error] [client 192.168.178.40] \tRose::DB::Object::Metadata::setup('SL::DB::Helper::Metadata=HASH(0x979e538)', 'table', 'periodic_invoice$
[Fri Jun 20 18:56:17 2014] [error] [client 192.168.178.40] \trequire SL/DB/MetaSetup/PeriodicInvoicesConfig.pm called at SL/DB/PeriodicInvoicesConfig.pm line 5
[Fri Jun 20 18:56:17 2014] [error] [client 192.168.178.40] \tSL::DB::PeriodicInvoicesConfig::BEGIN() called at SL/DB/MetaSetup/PeriodicInvoicesConfig.pm line 0
[Fri Jun 20 18:56:17 2014] [error] [client 192.168.178.40] \teval {...} called at SL/DB/MetaSetup/PeriodicInvoicesConfig.pm line 0
[Fri Jun 20 18:56:17 2014] [error] [client 192.168.178.40] \trequire SL/DB/PeriodicInvoicesConfig.pm called at SL/OE.pm line 43
[Fri Jun 20 18:56:17 2014] [error] [client 192.168.178.40] \tOE::BEGIN() called at SL/DB/MetaSetup/PeriodicInvoicesConfig.pm line 0
[Fri Jun 20 18:56:17 2014] [error] [client 192.168.178.40] \teval {...} called at SL/DB/MetaSetup/PeriodicInvoicesConfig.pm line 0
[Fri Jun 20 18:56:17 2014] [error] [client 192.168.178.40] \trequire SL/OE.pm called at SL/Form.pm line 63
[Fri Jun 20 18:56:17 2014] [error] [client 192.168.178.40] \tForm::BEGIN() called at SL/DB/MetaSetup/PeriodicInvoicesConfig.pm line 0
[Fri Jun 20 18:56:17 2014] [error] [client 192.168.178.40] \teval {...} called at SL/DB/MetaSetup/PeriodicInvoicesConfig.pm line 0
[Fri Jun 20 18:56:17 2014] [error] [client 192.168.178.40] \trequire SL/Form.pm called at SL/Dispatcher.pm line 24
[Fri Jun 20 18:56:17 2014] [error] [client 192.168.178.40] \tSL::Dispatcher::BEGIN() called at SL/DB/MetaSetup/PeriodicInvoicesConfig.pm line 0
[Fri Jun 20 18:56:17 2014] [error] [client 192.168.178.40] \teval {...} called at SL/DB/MetaSetup/PeriodicInvoicesConfig.pm line 0
[Fri Jun 20 18:56:17 2014] [error] [client 192.168.178.40] \trequire SL/Dispatcher.pm called at /var/www/kivitendo-erp/admin.pl line 5
[Fri Jun 20 18:56:17 2014] [error] [client 192.168.178.40] \tmain::BEGIN() called at SL/DB/MetaSetup/PeriodicInvoicesConfig.pm line 0

Sieht jemand mein Fehler?

0 Punkte

Ich habe für "SQL Ledger" (genauer gesagt "Ledgercart") auch das GD-Modul benötigt und musste einige Perl-Pakete nachrüste. Unter Debian heisst das Paket AFAIK "libgd-gd2-perl".

Den Rest müsste man mit

sudo cpan Modulename

nachrüsten können.

Beantwortet von (180 Punkte)
0 Punkte

Hallo,

ich bedanke mich für die Vorschläge.
Leider haben mir diese nicht geholfen.
In der Version 2.6.3 war es noch so bequem einfach deb Paket installieren und fertig.
Bei Linet habe ich auch schon nach dem Angebot für Update gefragt leider bis heute noch keine Antwort erhalten.
Ich werde dann die Version 2.6.3 beibehalten (solange diese funktioniert)
Es ist zwar schade jedoch ich kann hier nicht so viel Zeit in die Installation opfern.

Beantwortet von (100 Punkte)
0 Punkte

Hallo,

um die Installation der Perl-Pakete zu vereinfachen nutze ich (neben anderem) dafür Webmin. Dafür sollte es auch ein Paket in Ubuntu geben (glaube ich)

Dort gibt es den Menüpunkt "Perl-Pakete installieren" oder so ähnlich und dort dann einfach den Paketnamen der über 'installation_check.pl' angemeckert wird eingeben.

Webmin installiert das Paket wenn vorhanden über apt-get oder wenn nicht vorhanden über CPAN.

Good luck ;)

Henk

Beantwortet von (330 Punkte)

Ähnliche Fragen

0 Punkte
1 Antwort
0 Punkte
1 Antwort
Gefragt 21, Apr 2012 von martin (40 Punkte)
+1 Punkt
2 Antworten
Gefragt 25, Jan 2014 von andy232 (160 Punkte)
0 Punkte
1 Antwort
...