Willkommen im kivitendo Forum! Hier erweitern und teilen AnwenderInnen und EntwicklerInnen ihr Wissen.

Teste kivitendo!

kivitendo Demo

kivitendo Demo mit Schweizer Kontenplan

Geld allein macht nicht glücklich - benutzt kivitendo!

0 Punkte

Hallo zusammen,

gibt es hier jemanden, der kivi mit der o.g. Konstellation am Laufen hat? Anscheinend hat sich die Syntax der httpd. conf zu Apache 2.4.6 geändert. Gibt es dazu schon Erfahrungswerte?

Danke im Voraus.

Viele Grüße
Norbert

geschlossen mit Kommentar: Problem erledigt
Gefragt von (520 Punkte)
geschlossen von

1 Antwort

+1 Punkt

Hallo Norbert,

meines Wissens gibt es unter debianoiden Systemen nur eine /etc/apache2.conf und ein zugehöriges conf/ - Verzeichnis

Ich nutze Kivitendo incl. CRM auf einem Debian - Jessie. Das sollte nicht soweit weg von Ubuntu 13.10 sein.

Könntest Du Deine Frage bitte etwas präzisieren? (Fehlermeldungen, Log-Auszüge o.ä.)

VG
Henk

Beantwortet von (330 Punkte)

habs zum Laufen bekommen. Nachdem ich es mit normalem cgi geschafft hatte, habe ich mich langsam an die fcgi rangetastet. Bei meinem Server kommt noch dazu, dass es sich um einen Zentyal Server handelt, der die vhosts noch ein wenig anders regelt wir der normale ubuntu/apache server.

Das ist jetzt meine httpd.conf:

    AddHandler fcgid-script .fpl
AliasMatch ^/kivi/[^/]+\.pl /srv/www/kivi/dispatcher.fpl
Alias       /kivi/          /srv/www/kivi/
FcgidMaxRequestLen 10485760

<Directory /srv/www/kivi>
  #AllowOverride All
  Options ExecCGI Includes FollowSymlinks
  #Order Allow,Deny
  #Allow from All
  #Require all granted
</Directory>

<DirectoryMatch /srv/www/kivi/users>
  Order Deny,Allow
  #Deny from All
  Require all granted
</DirectoryMatch>

und die dazugehörige apache2.conf:

    # Sets the default security model of the Apache2 HTTPD server. It does
# not allow access to the root filesystem outside of /usr/share and /var/www.
# The former is used by web applications packaged in Debian,
# the latter may be used for local directories served by the web server. If
# your system is serving content from a sub-directory in /srv you must allow
# access here, or in any related virtual host.
<Directory />
	Options FollowSymLinks
	AllowOverride None
	Require all denied
</Directory>

<Directory /usr/share>
	AllowOverride None
	Require all granted
</Directory>

<Directory /var/www/>
	Options Indexes FollowSymLinks
	AllowOverride None
	Require all granted
</Directory>

<Directory /srv/>
	Options Indexes FollowSymLinks
	AllowOverride All
	Require all granted
</Directory>

Ob das jetzt der Weisheit letzter Schluß bezüglich der Sicherheit ist, kann ich nicht beurteilen, jedenfalls funktioniert es, und evtl. sollte die Doku bezüglich des "Require all granted" angepasst werden.

Vielen Dank für die Hilfe und Grüße aus dem Steigerwald,
Norbert

Ähnliche Fragen

0 Punkte
1 Antwort
0 Punkte
2 Antworten
Gefragt 28, Aug 2012 von torecki (20 Punkte)
0 Punkte
1 Antwort
...