Willkommen im kivitendo Forum! Hier erweitern und teilen AnwenderInnen und EntwicklerInnen ihr Wissen.

Teste kivitendo!

kivitendo Demo

kivitendo Demo mit Schweizer Kontenplan

Geld allein macht nicht glücklich - benutzt kivitendo!

0 Punkte

Ich benutze die Datenbank kivitendo_auth und habe Benutzer, Mandant und Gruppe angelegt. Beim Login und beim Starten des Task-Servers bekomme ich folgende Meldungen:
Oct 3 12:45:34 titan systemd[1]: Stopped kivitendo background jobs server.
Oct 3 12:45:39 titan systemd[1]: Starting kivitendo background jobs server...
Oct 3 12:45:44 titan task_server.pl[8712]: Starting kivitendo-background-jobs server
Oct 3 12:45:44 titan systemd[1]: Started kivitendo background jobs server.
Oct 3 12:45:44 titan kivitendo-background-jobs[8712]: Sucessfully daemonized
Oct 3 12:45:44 titan kivitendo-background-jobs[8712]: Filehandle STDIN reopened as FH only for output at /usr/share/perl5/File/Slurp.pm line 468.
Oct 3 12:45:44 titan kivitendo-background-jobs[8712]: Starting up...
Oct 3 12:45:44 titan kivitendo-background-jobs[8712]: DBD::Pg::st execute failed: ERROR: relation "background_jobs" does not exist
Oct 3 12:45:44 titan kivitendo-background-jobs[8712]: LINE 11: background_jobs t1
Oct 3 12:45:44 titan kivitendo-background-jobs[8712]: ^ at /usr/share/perl5/Rose/DB/Object/Manager.pm line 2016.
Oct 3 12:45:45 titan kivitendo-background-jobs[8712]: DBD::Pg::st execute failed: ERROR: relation "defaults" does not exist
Oct 3 12:45:45 titan kivitendo-background-jobs[8712]: LINE 1: SELECT * FROM defaults
Oct 3 12:45:45 titan kivitendo-background-jobs[8712]: ^ at /var/www/html/kivitendo-erp/scripts/../SL/DBUtils.pm line 150.

Eine Tabelle background_jobs gibt es tatsächtlich nicht. WIe lege ich sie an, was habe ich falsch gemacht?

geschlossen mit Kommentar: Problem besteht nicht mehr
Gefragt von (30 Punkte)
geschlossen von

1 Antwort

+1 Punkt

Ich würde eher einen professionellen Dienstleister anfragen, mit so wenig Infos kann man nur in die Glaskugel schauen:

Anyway, meine Glaskugel sagt:

relation "defaults" does not exist

kivitendo kann generell keine Verbindung zum DB-Server aufbauen.

Wurde den ein Mandant,sowie Benutzer und Gruppen angelegt?

Ok, die Info ist etwas untergegangen.

Der Taskserver muss mit einem Benutzer verknüpft werden, andernfalls kann er nicht wissen, für welchen Mandanten er arbeiten soll (das ist hier scheinbar der Fall, insofern eine Mandaten-DB angelegt wurde -> Geht der Benutzer-Login?)

Beantwortet von (6.5k Punkte)
Bearbeitet von

Danke für die schnelle Antwort.

Mandant, Benutzer und Gruppe waren angelegt und zu sehen. Auch die Verknüpfung des Benutzers mit dem Toolserver
habe ich überprüft. Nur einloggen konnte ich mich nicht.

Allerdings hatte ich beim ersten Durchlauf eine Fehlermeldung, als die Datenbank angelegt werden sollte.
Ich habe jetzt nochmal angefangen und alles in kivitendo_auth angelegt, und danach konnte ich mich einloggen.

...