Willkommen im kivitendo Forum! Hier erweitern und teilen AnwenderInnen und EntwicklerInnen ihr Wissen.

Teste kivitendo!

kivitendo Demo

kivitendo Demo mit Schweizer Kontenplan

Geld allein macht nicht glücklich - benutzt kivitendo!

0 Punkte

Hallo zusammen,
im üblichen Jahres-Turnus haben wir heute die aktuelle Minor-Version 3.5.3 freigegeben.

Details hierzu, wie immer im aktuellen Blog-Eintrag

Zusatz-Hinweis:

Die Installationsanleitung für fedora und debian wurde qualitätsgesichert, die Anleitung für OpenSuSE "nur" aktualisiert.

Gefragt von (6.1k Punkte)

1 Antwort

0 Punkte

Hallo jbueren,

die Installationsanleitung für Debian Stretch 9.6 ist fehlerhaft.

Siehe hier:
https://nopaste.linux-dev.org/?1191401

Das fehlende Paket gibt es bei Debian Testing Buster und es scheint auch zu fuktionieren:

cat /etc/apt/sources.list

deb cdrom:[Debian GNU/Linux 9.6.0 _Stretch_ - Official amd64 NETINST 20181110-11:34]/ stretch contrib main non-free

deb cdrom:[Debian GNU/Linux 9.6.0 _Stretch_ - Official amd64 NETINST 20181110-11:34]/ stretch contrib main non-free

deb http://debian.inf.tu-dresden.de/debian/ stretch main
deb-src http://debian.inf.tu-dresden.de/debian/ stretch main

deb http://security.debian.org/debian-security stretch/updates main contrib non-free
deb-src http://security.debian.org/debian-security stretch/updates main contrib non-free

stretch-updates, previously known as 'volatile'

deb http://debian.inf.tu-dresden.de/debian/ stretch-updates main contrib non-free
deb-src http://debian.inf.tu-dresden.de/debian/ stretch-updates main contrib non-free

for Kivitendo libhtml-restrict-perl, if install disable

deb http://debian.inf.tu-dresden.de/debian/ buster main

Die folgenden Pakete müssen auch noch installiert werden:

apt install libfile-mimeinfo-perl libpbkdf2-tiny-perl     libregexp-ipv6-perl

./installation_check.pl
https://nopaste.linux-dev.org/?1191406

So scheint es ok, jedoch bekomme ich keine Kivitendo Oberfläche.
Der Apacheserver ist erreichbar, wie suche ich den Fehler?

Der folgende Befehl aus der Anleitung funktioniert bei mir nicht:

chown -R www-data users spool webdav

chown: Zugriff auf 'users' nicht möglich: Datei oder Verzeichnis nicht gefunden
chown: Zugriff auf 'spool' nicht möglich: Datei oder Verzeichnis nicht gefunden
chown: Zugriff auf 'webdav' nicht möglich: Datei oder Verzeichnis nicht gefunden

Wie gehe ich damit um?

Mit welchem Linux funktioniert eure Anleitung?

Beantwortet von (260 Punkte)
Bearbeitet von

Hallo, mein ./installation_check.pl ist ok

Da ich das Gesamtpaket nicht checke, brauche ich kleinere Pakete um zu verstehen.
Besonders die Auswirkungen der Passwörter sind mir nicht geläufig.

2.5. Anpassung der PostgreSQL-Konfiguration

Dies Kapitel habe ich erledigt, wie prüfe ich nun, ob ich bis dahin die Passwörter richtig einsetze und ob mein PostgreSQL für Kivitendo richtig eingerichtet ist?

local all kivitendo password

host all kivitendo 127.0.0.1 255.255.255.255 password

Was ist hier bei "password" einzugeben, oder das password hier eine Variable?

2.5.3. Erweiterung für servergespeicherte Prozeduren

In der Datenbank template1 muss die Unterstützung für servergespeicherte Prozeduren eingerichet werden. Melden Sie sich dafür als Benutzer “postgres” an der Datenbank an:

Kann dieser Benutzer von "root" erreicht werden?

Danke für die Hilfe.

tstrebel

Kurz mal die Gegenfragen:

i)
Läuft Dein Webserver?
ii)
Kannst Du die Anwendung aufrufen?

Dann rückwärts die Antworten:

Kann dieser Benutzer von "root" erreicht werden?
Ja, :

su - postgres
psql

Im Prinzip brauchst Du jetzt nur dem kivitendo Benutzer in postgres anlegen und Rechte geben.
Die Datenbanken werden dann über die Web-Oberfläche erzeugt.

Die serverseitige Prozedur ist mittlerweile bei modernen Distrbution drin.

Ich mach die Schritte kurz mit ubuntu 18, parallel:

specht@specht-kivitendo:~$ sudo su - postgres
[sudo] password for specht: 
postgres@specht-kivitendo:~$ psql
psql (10.6 (Ubuntu 10.6-0ubuntu0.18.04.1))
Type "help" for help.

postgres=# CREATE EXTENSION IF NOT EXISTS plpgsql;
NOTICE:  extension "plpgsql" already exists, skipping
CREATE EXTENSION
postgres=# \q

Damit ist 2.5.3 erledigt und schon standardmäßig drin.

Jetzt die wirklich wichtige Frage kivitendo-Benutzer, die Antwort steht in der Doku im Kapitel 2.5.5
Auch nochmal parallel, inkl. Test:

postgres@specht-kivitendo:~$ createuser -d -P kivitendo
Enter password for new role: 
Enter it again: 

Ein Test auf der Kommandozeile mit dem Parameter -U für Benutzer:

postgres@specht-kivitendo:~$ psql -U kivitendo template1
Password for user kivitendo: 
psql (10.6 (Ubuntu 10.6-0ubuntu0.18.04.1))
Type "help" for help.

template1=> \q

Hallo, mein Stand:

  • Ubuntu Server 18.04.2 installiert

  • Login per ssh user@192.....

  • sudo apt install apache2 libarchive-zip-perl libclone-perl \
    libconfig-std-perl libdatetime-perl libdbd-pg-perl libdbi-perl \
    libemail-address-perl libemail-mime-perl libfcgi-perl libjson-perl \
    liblist-moreutils-perl libnet-smtp-ssl-perl libnet-sslglue-perl \
    libparams-validate-perl libpdf-api2-perl librose-db-object-perl \
    librose-db-perl librose-object-perl libsort-naturally-perl \
    libstring-shellquote-perl libtemplate-perl libtext-csv-xs-perl \
    libtext-iconv-perl liburi-perl libxml-writer-perl libyaml-perl \
    libimage-info-perl libgd-gd2-perl libapache2-mod-fcgid \
    libfile-copy-recursive-perl postgresql libalgorithm-checkdigits-perl \
    libcrypt-pbkdf2-perl git libcgi-pm-perl libtext-unidecode-perl libwww-perl\
    postgresql-contrib aqbanking-tools poppler-utils libhtml-restrict-perl\
    libdatetime-set-perl libset-infinite-perl liblist-utilsby-perl\
    libdaemon-generic-perl libfile-flock-perl libfile-slurp-perl

  • cd /var/www/

  • sudo git clone https://github.com/kivitendo/kivitendo-erp.git
  • cd kivitendo-erp/
  • sudo git checkout git tag -l | egrep -ve "(alpha|beta|rc)" | tail -1
  • sudo git checkout -b meine_eigenen_änderungen
  • sudo cp config/kivitendo.conf.default config/kivitendo.conf

  • cat config/kivitendo.conf (Passwort ist admin123, also keine Änderungen der Defaultvorlage)

  • cd /var/www/kivitendo-erp/scripts

  • ./installation_check.pl
    es fehlen einige Pakete
  • sudo apt install libfile-mimeinfo-perl libpbkdf2-tiny-perllibregexp-ipv6-perl
    Erneut
  • ./installation_check.pl
    jetzt ist all grün, also ok
  • sudo su postgres
  • echo '\l' | psql
  • exit

  • sudo nano /etc/postgresql/10/main/postgresql.conf (nur angeschaut)

  • sudo nano /etc/postgresql/10/main/pg_hba.conf (angehängt local all kivitendo password
    host all kivitendo 127.0.0.1 255.255.255.255 password)

Bei Aufruf der ip address des Server wird im Browser angezeigt "Das Apache2 Ubuntu Default Page"

createuser -d -P kivitendo, mein Passwort ist für kivitendo "admin123"

Jetzt die wirklich wichtige Sache:

postgres@ubu1804:~$ createuser -d -P kivitendo

Enter password for new role:
Enter it again:
createuser: creation of new role failed: ERROR: role "kivitendo" already exists
postgres@ubu1804:~$

Was mache ich nur falsch?

Deine Anleitung hier, sieht für irgendwie anderas aus, als die offizielle Anleitung.
In der offiziellen Anleitung fehlen unter anderem auch die Pakete "sudo apt install libfile-mimeinfo-perl libpbkdf2-tiny-perllibregexp-ipv6-perl"

MfG

tstrebel

Fragen vom jbueren ----->

Kurz mal die Gegenfragen:

i)
Läuft Dein Webserver? -- wie stelle ich das fest?

ii)
Kannst Du die Anwendung aufrufen? -- welche Anwedung genau, wie prüfe ich das?

Hi,
es fehlt jetzt ein bisschen technisches Grundlagenwissen.

Am Einfachsten wäre es, wenn Du entweder bei Chemnitzer-Linux-Tag oder bei der FrOSCon vorbeischaust.

Da können wir weiterhelfen.

Alternativ gibt es bestimmt eine Linux-User-Group oder FSFE-Initiative in Deiner Umgebung, die helfen bestimmt auch.

Last, not least gibt es noch die offiziellen (kommerziellen) kivitendo Partner.

Hallo, stimmt, ich dachte die Community kann mir helfen.

Wieso stimmt die Anleitung nicht genau?

Wurde das nicht vollständig getestet?

MfG

tstrebel

Ich bastel mal da weiter: https://forum.kivitendo.de/4432/kivitendo-3-5-3-mit-ubuntu-server-18-04-2-als-anfänger

Ähnliche Fragen

0 Punkte
1 Antwort
Gefragt 23, Feb 2014 von puba (480 Punkte)
0 Punkte
1 Antwort
0 Punkte
2 Antworten
0 Punkte
2 Antworten
Gefragt 31, Mär 2018 von silencer2010 (850 Punkte)
0 Punkte
1 Antwort
...