Willkommen im kivitendo Forum! Hier erweitern und teilen AnwenderInnen und EntwicklerInnen ihr Wissen.

Teste kivitendo!

kivitendo Demo

kivitendo Demo mit Schweizer Kontenplan und neuem Layout

Geld allein macht nicht glücklich - benutzt kivitendo!

0 Punkte

Hallo,

wir sind mit unserer Kivitendo-Datenbank auf einen neuen Rechner umgezogen. Die Sicherung unserer Vorlagen zum Druck sind im templates-Verzeichnis. Leider müssen wir nun feststellen, dass der Druck unseres Firmenlogos nicht mehr funktioniert. Die PDF-Erstellung schlägt fehl mit der Meldung:

! Package pdftex.def Error: File `logo' not found: using draft setting.
See the pdftex.def package documentation for explanation.
Type H for immediate help.
l.3 \includegraphics[width=8cm]{logo}

Zur Information, auf unserem alten Rechner läuft der Druck ohne Probleme, in der neuen Installation erscheint diese Fehlermeldung

Unser alter Rechner arbeitet mit Ubuntu 12.04, die neue Maschine mit debian10 . Die kivitendo-Version ist die gleiche - 3.5.0 .

Welche Möglichkeiten bleiben uns, um unsere Druckvorlagen weiter nutzen zu können?

Vielen Dank

Thomas

Gefragt von (60 Punkte)

2 Antworten

+1 Punkt
 
Beste Antwort

Hallo Thomas,

schau Dir mal den commit f46ac9daca71a6e0c4ca480a3f826fd2871182a2 an:
(https://github.com/kivitendo/kivitendo-erp/commit/f46ac9daca71a6e0c4ca480a3f826fd2871182a2).

Wahrscheinlich hat es damit zu tun. Der ist in der 3.5.4 drin.

Viele Grüße
Bernd

Beantwortet von (4.9k Punkte)
ausgewählt von

der Link hat mich auf die richtige Spur gebracht.
Wir haben jetzt unsere logo-Datei aus dem template Verzeichnis in das kivitendo/users Verzeichnis kopiert, damit funktioniert der Druck von pdf-Dateien einwandfrei.

Dankeschön Bernd

0 Punkte

Hallo
speichere mal das Bild mit endung ab z.B. logo.png und binde es auch so ein \includegraphics[width=8cm]{logo.png}

Beste Grüße
Werner kivitendodienstleister

Beantwortet von (7k Punkte)

Hallo,

leider muss ich sagen egal ob ich dieses Bild mit oder ohne Dateierweiterung einbinde, es ist immer die selbe Fehlermeldung.
Inzwischen komme ich zu der Auffassung, dass der Fehler irgendwo im Zusammenspiel zwischen debian10 und den alten LaTex-Vorlagen liegt.

Als Zwischenlösung haben wir eine weitere virtuelle Maschine aufgesetzt und auf dieser ein Ubuntu installiert. Danach unsere Datenbank mit den alten Druckvorlagen übernommen. Dazu eine ältere Version von texlive und es funktioniert, wir haben wieder Zugriff auf unsere Kivitendo-Druckvorlagen.

Das löst natürlich nicht das eigentliche Problem, dennoch so sind wir erst einmal arbeitsfähig.

Deshalb bin ich weiter an möglichen Lösungen interessiert, unsere alten LaTex-Vorlagen in der neuesten kivitendo-Version in debian10 zu nutzen.

Thomas

Hallo Thomas,
dir ist schon bewusst, dass die neue kivitendoversion 3.5.6 ist und du noch die 3.5.0 benutzt?

Beste Grüße
Werner kivitendodienstleister

Ähnliche Fragen

0 Punkte
2 Antworten
Gefragt 28, Dez 2014 von sisqonrw (1.7k Punkte)
0 Punkte
0 Antworten
Gefragt 23, Apr 2017 von carstenk70 (190 Punkte)
0 Punkte
1 Antwort
0 Punkte
2 Antworten
0 Punkte
2 Antworten
Gefragt 3, Sep 2019 von andy232 (160 Punkte)
...