Willkommen im kivitendo Forum! Hier erweitern und teilen AnwenderInnen und EntwicklerInnen ihr Wissen.

Teste kivitendo!

kivitendo Demo

kivitendo Demo mit Schweizer Kontenplan und neuem Layout

Geld allein macht nicht glücklich - benutzt kivitendo!

0 Punkte

Nun, ich komme mir selbst recht blöd vor. Bei der Installation von 2.7 (ich arbeite seit langem mit 2.6x) möchte ich meine Installation austesten und versuche die admin.pl aufzurufen. Mein Browser bietet mir an, die Datei downzuloaden. Wie das? Meine Vermutung auf nicht ausreichende Rechte und das die Datei evtl. nicht als ausführbar markiert wurde trafen nicht zu. Was kann es noch sein?
Ich habe die Installation auf Ubuntu 12.04 LTS gespielt. Die Endung pl bedeutet das es sich um ein Perlskript handelt?
Danke

Gefragt von (90 Punkte)
wieder getaggt von

2 Antworten

0 Punkte
 
Beste Antwort

Was kann es noch sein?

Apache Config
eine gueltige AddHandler Direktive
im entsprechenden Verzeichnis die Option ExecCGI gesetzt

Das ganze ist hier:
https://demo.kivitendo.de/doc/html/ch02s05.html#Apache-Konfiguration
beschrieben.

Beantwortet von (17.9k Punkte)
ausgewählt von
0 Punkte

OK. Dann hat es nicht mit den von mir angesprochenen Problemen zu tun. Vermutlich liegt es an den Apache Einstellungen. Ich habe FastCGI installiert, da ich das Paket FCGI nicht gefunden und installieren konnte. Ich habe die Apache Config so geändert, das aus "fcgi" "fastcgi" gemacht. In der Anleitung wurde auch nur die Variante mit fcgi beschrieben.
Der Testdurchlauf zu Beginn der Installation mit dem Testscript zeigte bis auf FastCGI alle anderen Voraussetzungen grün an.
Ich ändere mal das auf eine Standardumgebung und sehe was geschieht.
Danke erstmal...
Michael

Beantwortet von (90 Punkte)

Du hast bestimmt gesehen das auch das FASTCgi Modul aktiviert ist. Wie kann ich das ausschalten?

das wird ueber Symlinks in /etc/apache2/mods-enabled/ gesteuert und es gibt den Befehl

man a2enmod

Bestimmt beißen sich die beiden CGI Module!!

hatte sschoeling beantwortet

Mein Vorschlag:

  • Uberlege Dir unter welcher URL Kivitendo erreichbar sein soll.

  • pack Deine Apache-config mal bei Seite und mach eine Neue (um einfach mal 'uebersicht zu bekommen)

  • orientiere Dich an https://demo.kivitendo.de/doc/html/ch02s05.html#d0e51
    also zunaechst ohne fcgi. (in Deiner aktuellen Config fehlt dazu der AddHandler cgi-script .pl aber wie gesagt, fang mal von vorne an)

  • Apache durchstarten nicht vergessen!

  • Wenn das geht (und erst dann) aenderst Du die Datei so, dass fcgi geht.

  • Modul aktivieren nicht vergessen

Hallo ich habe mich an deinen Rat gehalten und zunächst eine rudimentäre und träge Konfiguration ins Apache sites-available geschrieben:

<VirtualHost *:80>
	ServerAdmin webmaster@localhost

	DocumentRoot /var/www
	<Directory />
		Options FollowSymLinks
		AllowOverride None
	</Directory>
	<Directory /var/www/>
		Options Indexes FollowSymLinks MultiViews
		AllowOverride None
		Order allow,deny
		allow from all
	</Directory>

	ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
	<Directory "/usr/lib/cgi-bin">
		AllowOverride None
		Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
		Order allow,deny
		Allow from all
	</Directory>

	ErrorLog ${APACHE_LOG_DIR}/error.log

	# Possible values include: debug, info, notice, warn, error, crit,
	# alert, emerg.
	LogLevel warn

	CustomLog ${APACHE_LOG_DIR}/access.log combined

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

   

   AddHandler cgi-script .pl
   Alias /lx-erp/ /var/www/lx-erp/

   <Directory /var/www/lx-erp>
 	Options ExecCGI
        Includes FollowSymlinks
   </Directory>

  <Directory /var/www/lx-erp/users>
    Order Deny,Allow
    Deny from All
  </Directory>

</VirtualHost>
Syntax error on line 48 of /etc/apache2/sites-enabled/000-default:
Invalid command 'Includes', perhaps misspelled or defined by a module not included in the server configuration
Action 'configtest' failed.
The Apache error log may have more information.
   ...fail!

Und nun? Es darf auch nicht "Include FollowSymlinks" heißen. Da spukt der Rechner die selben Beschwerden aus.

Und dann ist dan noch der Code:

# Zugriff mit mod_fcgid:
    	AliasMatch ^/localhost/**lx-erp-fcgid**/[^/]+\.pl /var/www/lx-erp/dispatcher.fpl
    	Alias       /localhost/**lx-erp-fcgid**/          /var/www/lx-office-erp/

wobei es das verzeichnis lx-erp-fcgid überhaupt nicht gibt. Welchen blöden Fehler begehe ich da?

>

<Directory /var/www/lx-erp>
 Options ExecCGI
       Includes FollowSymlinks   

</Directory>

der Umbruch ist ein Formatierungsfehler in der online-Doku es muss heissen:
(das Forum formatiert hier auch staendig um, ....)

 <Directory /var/www/lx-erp>
    Options ExecCGI  Includes FollowSymlinks
   </Directory>

(ich korrigiere das in der Entwicklerversion)
Lass uns erst weitermachen, wenn es unter cgi lauft,

Hallo,

LX läuft nach der Entfernung des Zeilenumbruchs.

Ich ändere nun mal die Apache Config auf FCGI..........

Ich ändere nun mal die Apache Config auf FCGI..........

funktioniert's?

Feedback ist natuerlich imer nett, wenn man sich Muehe mit der Antwort gegeben hat.

...