Willkommen im kivitendo Forum! Hier erweitern und teilen AnwenderInnen und EntwicklerInnen ihr Wissen.

Teste kivitendo!

kivitendo Demo

kivitendo Demo mit Schweizer Kontenplan

Geld allein macht nicht glücklich - benutzt kivitendo!

0 Punkte

Hallo,

sorry, daß ich mich 2 Wochen nicht gemeldet habe, aber mir ist was dazwischen gekommen. Jetzt rätsele ich wieder am Kvitiendo.

ich habe eine Datei für das erwähnte Skript angelegt und dann wie beschrieben ausgeführt. Allerdings ist nichts passiert. Im Terminal wurde einfach eine Reihe weitergeschaltet und war alles. Ich habe nach wie vor eine weiße, leere Seite wenn ich mich einloggen will. Will ich jetzt aber das Terminal-Fenster schließen, meckert Ubuntu, daß noch ein Prozess laufen würde.

Bis dann

bezieht sich auf eine Antwort auf: Task Server will nicht laufen (exit with error code)
Gefragt von (250 Punkte)

1 Antwort

0 Punkte
 
Beste Antwort
  1. terminal öffnen
  2. sudo su
  3. cd
  4. mkdir work
  5. cd work
  6. git clone https://github.com/kivitendo/kivitendo-crm.git
  7. cd kivitendo-crm/install/
  8. ./install-Kivitendo-on-Ubuntu-18.04.sh

Anweisungen im Terminal folgen.
ERP: letzte stabile Version wählen
CRM: aktuelle Git-Version wählen
Im Browser zuerst: localhost/kivitendo-erp/admin.pl
danach: localhost/kivitendo-erp/

  1. rm -R ~/work

Fertig. Funktioniert. 100%

Bei Problemen:
(als root im terminal)
cd /var/www/kivitendo-erp
./scripts/installation_check.pl

tail -f /var/log/apache2/error.log

Viel Spaß mit Kivitendo!

Ronny

Beantwortet von (8.2k Punkte)
ausgewählt von

Hallo,

danke für deine Antwort leider funktioniert es immer noch nicht. Installation_check meldet

"Set::Crontab 1.03 not ok.

Im Brower bei Aufruf von admin.pl kommt folgende Fehlermeldung:

*

Fehler! Während der Ausführung trat eine Ausnahme auf. Typ: undef
Information: get_objects() - DBD::Pg::st execute failed: ERROR:
column t1.task_server_user_id does not exist LINE 10:
t1.task_server_user_id

       ^ at /usr/share/perl5/Rose/DB/Object/Manager.pm line 2016.  at /var/www/kivitendo-erp/SL/Controller/LoginScreen.pm line 170.

*

in der Datei Manager.pm unter Zeile 2016 findet sich dies:

    $sth->execute(@$bind);

und unter Zeile 170 bei LoginScreen.pm findet sich:

return SL::DB::Manager::AuthClient->get_all_sorted;

tail -f /var/log/apache2/error.log liefert das:

[Wed Jul 03 13:58:35.059622 2019] [core:notice] [pid 5521] AH00094: Command line: '/usr/sbin/apache2'
[Wed Jul 03 13:58:35.951752 2019] [mpm_prefork:notice] [pid 5521] AH00169: caught SIGTERM, shutting down
[Wed Jul 03 13:58:36.692234 2019] [mpm_prefork:notice] [pid 5608] AH00163: Apache/2.4.29 (Ubuntu) mod_fcgid/2.3.9 configured -- resuming normal operations
[Wed Jul 03 13:58:36.692308 2019] [core:notice] [pid 5608] AH00094: Command line: '/usr/sbin/apache2'
[Wed Jul 03 14:00:47.063563 2019] [mpm_prefork:notice] [pid 5608] AH00169: caught SIGTERM, shutting down
[Wed Jul 03 14:00:47.375771 2019] [mpm_prefork:notice] [pid 6735] AH00163: Apache/2.4.29 (Ubuntu) mod_fcgid/2.3.9 configured -- resuming normal operations
[Wed Jul 03 14:00:47.375847 2019] [core:notice] [pid 6735] AH00094: Command line: '/usr/sbin/apache2'
[Wed Jul 03 14:16:09.751382 2019] [mpm_prefork:notice] [pid 6735] AH00169: caught SIGTERM, shutting down
[Wed Jul 03 14:16:14.931231 2019] [mpm_prefork:notice] [pid 9473] AH00163: Apache/2.4.29 (Ubuntu) mod_fcgid/2.3.9 configured -- resuming normal operations
[Wed Jul 03 14:16:14.931330 2019] [core:notice] [pid 9473] AH00094: Command line: '/usr/sbin/apache2'

Ich hoffe, du kannst mir nochmal helfen. :D

"Set::Crontab 1.03 not ok.

als root in der Console:

cd /var/www/kivitendo-erp/

wenn du "./scripts/installation_check.pl" ausführst steht unten eine Zeile wie apt install xyz oder cpan install xyz
führe diese aus.

welche ERP version hast du ausgecheckt??

die letzte stable checkst du mit "git checkout release-3.5.3"
benutze diese

Hi,
kurze Anmerkung:

Deine kivitendo Version ist weder eine 3.5.3 stable noch die allerneuste git-Version.

Ich vermute dass irgendwo auf Deinem System noch die Version von März/2019 rumliegt und Dein Webserver diese verwendet.

Im nächsten Schritt würde ich erstmal sicherstellen, dass du entweder die 3.5.3 stable oder eine Version ab Juni 2019 vom Webserver gezogen wird.

Bei beiden Varianten wird Set::Crontab nicht angemeckert, dass sollte als erster Test ausreichen (siehe auch meine Anmerkung zum vorherigen Thread).

Die Entwicklerversion von März bis Mai 2019 hat auf jeden Fall ein Problem ganz neue Datenbanken zu erzeugen.

Allerdings bist du scheinbar bisher noch nicht bis zu diesem Schritt gekommen, s.a. https://www.kivitendo.de/redmine/issues/376

Für die Leute, die es genauer wissen wollen:

Set::Crontab wurde bis zur Version 3.5.3 als Modul innerhalb kivitendos mitgeliefert.

Um kivitendo etwas fedora-konformer zu machen, wurden Anfang des Jahres relativ viele Abhängigkeiten nicht mehr mitgeliefert, da die Distributions-Maintainer (zu Recht) meinten, dass die Fixes und Patches für die Module schneller verfügbar sind, wenn diese nicht gebündelt mitgeliefert werden.

Auf der anderen Seite hat der Debian Maintainer von Set::Crontab seit 2011 nicht gesehen, dass für Set::Crontab eine Version 1.03 existiert.

Das ist mittlerweile geändert und die 1.03 ist ab Debian Buster (ubuntu 19) verfügbar.

Wir haben dann (roundabout April 2019) entschieden, die marginalen Unterschiede von 1.03 in Betracht auf 1.02 für kivitendo als irrelevant einzustufen und diese Prüfung dann aus dem installation_check entfernt.

Die kivitendo 3.5.4 Beta wird diesen Monat noch erscheinen, dann sollte auch ein

cat VERSION

eine geänderte Versionsnummer liefern.

Gruß

Hallo,

danke für die Hinweise. Ich habe jetzt mit dem Hinweis von Ciatronical, den Fehler mit Set::crontab beseitigen können. installation_check läuft jetzt alles in grün durch. Allerdings hat sich an der Log-In-Seite noch nichts geändert. Es gibt weithin die o. g. Meldung. Im Dialogfenster des Installationsscriptes habe ich die Version 3.5.3 angehakt.

Ich habe auch noch das Verzeichnis (mit Inhalt) der Version 3.0.0 auf dem Rechner, die läuft aber seit dem Update auf Ubuntu 18.04 auch nicht mehr. Wie kann ich denn evtl. vorhandene störende Versionen deinstallieren? Es läuft ja nicht, einfach löschen geht sicher nicht, oder?

Viele Grüße

Kannst Du den aktuell produktiv mit kivi arbeiten?

Die Version 3.0.0 stört wahrscheinlich nicht, eher die Tatsache, dass die 3.5.3 auf den Datenbestand der 3.0.0 zeigt.

in config/kivitendo.conf steht hier der Wert für die sogenannten Auth-DB, die sollte dann für die 3.5.3 leicht anders heißen oder aber du machts ein Upgrade der Datenbanken.

Solange du produktiv irgendwo arbeiten kannst, würde ich weiterrumbasteln, ansonsten hatte der Werner mit dem Zaunpfahl: 'Ich bin ein kivitendo-Dienstleister' gewunken ....

Hallo,

bisher ging es nicht, aber nun aus heiterem Himmel kann erscheint soeben die CRM-Login-Seite.

Vielen Dank für eure Hilfe.

Ähnliche Fragen

0 Punkte
2 Antworten
Gefragt 3, Jan 2013 von pseher (830 Punkte)
0 Punkte
1 Antwort
0 Punkte
1 Antwort
Gefragt 11, Jun 2018 von nschneider (330 Punkte)
0 Punkte
1 Antwort
Gefragt 24, Sep 2016 von holzwurm (310 Punkte)
+1 Punkt
0 Antworten
...