Willkommen im kivitendo Forum! Hier erweitern und teilen AnwenderInnen und EntwicklerInnen ihr Wissen.

Teste kivitendo!

kivitendo Demo

kivitendo Demo mit Schweizer Kontenplan und neuem Layout

Geld allein macht nicht glücklich - benutzt kivitendo!

0 Punkte

Hallo zusammen,

ich brauche Eure Hilfe. Ich drucke auf Rechnungen einen Girocode mit dem qrcode.sty package. Wenn ich ZUGfERD Erzeugung einschalte, dann bricht LaTeX mit einem Fehler ab.

Für die Erzeugung des QR-Codes habe ich diesen Text in invoice.tex am Ende eingebunden.



\qrcode*[level=M]{BCD
001
1
SCT



EUR<%invtotal%>
}
\end{document}

Die LaTeX Fehlermeldung ist:

! Incomplete \iffalse; all text was ignored after line 237.

\fi
<> kivitendo-print-20200906163659-kTKluN.tex
! Emergency stop.
<
> kivitendo-print-20200906163659-kTKluN.tex

Zeile 237 ist '}' vor \end{document}. Wenn ich entweder den \qrcode Befehl herausnehme oder in Mandanatekonfiguration ZUGfERD Erzeugung abschalte, dann wird die Rechnung normal erzeugt.

Viele Grüße
Klaus

Gefragt von (70 Punkte)
Bearbeitet von

1 Antwort

0 Punkte

Hallo Klaus,

ich verwende als Basis die Templates von marei und habe dort in invoice.tex Dein Code-Fragment and das Ende der Datei, aber vor \end{letter} und \end{document} einkopiert.

Die ZUGfERD-Rechnung wurde fehlerfrei erzeugt.

Mal abgesehen davon, dass der Euro-Betrag anstatt eines Punktes ein Komma enthält, scheint das Paket zu funktionieren.

Gruß
Hans-Jürgen

Beantwortet von (840 Punkte)

Hallo Hans-Jürgen,

Danke für Deinen Test. Ich habe verwende angepasste Templates aus einer älteren Version. Ich habe der Reihe nach alle Textbausteine ausgenommen. Dabei fand ich, dass in inheaders.tex das Problem liegt. Das Problem war das deutsche Sprachpaket.


\usepackage{german}

ich habe durch diese Anweisung ersetzt. Damit bekommt man die gleichen Einstellungen.

\usepackage[german]{babel}

Hier wird german als Option des Paketes babel gesetzt. Das scheint stabilere Definitionen zu bringen.
Vielen Dank für Deine Hilfe.

Viele Grüße
Klaus

wegen des kommas
benutze <%invtotal NOFORMAT%>

NOFORMAT geht für alle Zahlen

Beste Grüße
Werner kivitendodienstleister

Nochmal Danke an Euch beide. Ich hatte übersehen, dass der Girocode den Betrag als #.## definiert. Bei meiner Banking App wird '.' und ',' akzeptiert.

Viele Grüße
Klaus

Ähnliche Fragen

0 Punkte
1 Antwort
0 Punkte
1 Antwort
Gefragt 30 Jul von HJG (840 Punkte)
0 Punkte
1 Antwort
0 Punkte
2 Antworten
0 Punkte
0 Antworten
...