Willkommen im kivitendo Forum! Hier erweitern und teilen AnwenderInnen und EntwicklerInnen ihr Wissen.

Teste kivitendo!

kivitendo Demo

kivitendo Demo mit Schweizer Kontenplan

Geld allein macht nicht glücklich - benutzt kivitendo!

0 Punkte

Hi,

beim Aufruf von ./scripts/installation_check.pl

ist Net::SMTP::SSL und Net::SSLGlue nicht gelistet, obwohl libnet-smtp-ssl-perl libnet-sslglue-perl installiert,
wieso denn das und wie geht es weiter?

kleine Frage++:
Email::Address und List::MoreUtils stehen in der Liste (Script Aufruf),
bedeutet dies das sie in der Bibliothek drin sind? Grund folgender Satz in der doku:Email::Address und List::MoreUtils sind schon länger feste Abhängigkeiten, wurden aber bisher mit kivitendo mitgeliefert. Beide sind auch in 2.6.1 weiterhin mit ausgeliefert, wurden in einer zukünftigen Version aber aus dem Paket entfernt werden. Es wird empfohlen diese Module zusammen mit den anderen als Bibliotheken zu installieren.

Gefragt von (2.4k Punkte)
Bearbeitet von

1 Antwort

0 Punkte
 
Beste Antwort

Koenntest du bitte noch alle Versionen (kivitendo, perl-pakete) mit angeben? Vielleicht ist da ein Problem..

Beantwortet von (1k Punkte)
ausgewählt von

Klar doch, Kivitendo 3.1.0 (neu bzw. erst Installation) und folgend die komplette Liste von der Abfrage:

./scripts/installation_check.pl -ro

Checking Required Modules:
Looking for parent ....................................................... 0.225
Looking for Archive::Zip 1.16 ............................................. 1.30
Looking for Clone ......................................................... 0.31
Looking for Config::Std .................................................... 0.9
Looking for DateTime ...................................................... 0.75
Looking for DBI 1.50 ..................................................... 1.622
Looking for DBD::Pg 1.49 ................................................ 2.19.2
Looking for Email::Address ............................................... 1.895
Looking for Email::MIME .................................................. 1.910
Looking for FCGI 0.72 ..................................................... 0.74
Looking for File::Copy::Recursive ......................................... 0.38
Looking for JSON .......................................................... 2.53
Looking for List::MoreUtils 0.21 .......................................... 0.33
Looking for Params::Validate .............................................. 1.06
Looking for PDF::API2 2.000 .............................................. 2.019
Looking for Rose::Object ................................................. 0.859
Looking for Rose::DB ..................................................... 0.769
Looking for Rose::DB::Object 0.788 ....................................... 0.798
Looking for String::ShellQuote 1.01 ....................................... 1.03
Looking for Sort::Naturally ............................................... 1.02
Looking for Test::Harness 3.00 ............................................ 3.23
Looking for Template 2.18 ................................................. 2.24
Looking for Text::CSV_XS 0.23 ............................................. 0.90
Looking for Text::Iconv 1.2 ................................................ 1.7
Looking for URI 1.35 ...................................................... 1.60
Looking for XML::Writer 0.602 ............................................ 0.615
Looking for YAML 0.62 ..................................................... 0.62

Checking Optional Modules:
Looking for Digest::SHA ................................................... 5.61
Looking for IO::Socket::SSL ............................................... 1.76
Looking for Net::LDAP ..................................................... 0.44
Looking for Net::SMTP::SSL ................................................ 1.01
Looking for Net::SSLGlue .................................................. 1.01

Result:
All ......................................................................... OK

Ok. 1. wollte ich eigentlich noch die Versionen der Debian-Packages: libnet-smtp-ssl-perl libnet-sslglue-perl
Zum direkten Vergleich.

Aber das scheint ja nun auch nicht mehr noetig, denn deine Pakete sind ja gelistet:

Looking for Net::SMTP::SSL ................................................ 1.01
Looking for Net::SSLGlue .................................................. 1.01

..?

sind halt optionale Module und werden nur mit dem Schalter "-o" angezeigt. also auch: Alles gut! :)

Oder?

OK das ist mir noch gar nicht aufgefallen das mit der Option -o beide gelistet sind.
Danke dir für die Klärung und ja damit dürfte es gut sein.

Ähnliche Fragen

0 Punkte
1 Antwort
0 Punkte
0 Antworten
0 Punkte
1 Antwort
0 Punkte
2 Antworten
Gefragt 5, Jul 2013 von jan-helbling (690 Punkte)
...